Help (again)! Bad Behavior Extension not working

apps

#1

Hi there,
Similar to my other post (Spam Blacklist), I’m having trouble with the “Bad Behavior” extension. I’ve tried installing the extension as explained at the Homeland Stupidity website. I have downloaded the latest PHP files and saved them to a “Bad-Behavior” folder in my extensions directory. I have also included the following code in my LocalSettings.php file:

include_once( ‘includes/DatabaseFunctions.php’ );
include( ‘./extensions/Bad-Behavior/bad-behavior-mediawiki.php’ );

However, when I go to my wiki site, I receive error messages:


Detected bug in an extension! Hook bb2_mediawiki_timer
failed to return a value; should return true to
continue hook processing or false to abort.

Backtrace:

#0
/home/.whoopi/username/website.com/wiki/includes/Parser.php(386):
wfRunHooks()
#1
/home/.whoopi/username/website.com/wiki/includes/Article.php(3017):
Parser->parse(‘ParserAfterTidy’, Array)
#2
/home/.whoopi/username/website.com/wiki/includes/Article.php(831):
Article->outputWikiText(’’’‘MediaWi…’,
Object(Title), Object(ParserOptions), true, true, 5)
#3
/home/.whoopi/username/website.com/wiki/includes/Wiki.php(383):
Article->view(’’’‘MediaWi…’)
#4
/home/.whoopi/username/website.com/wiki/includes/Wiki.php(48):
MediaWiki->performAction()
#5
/home/.whoopi/username/website.com/wiki/index.php(89):
MediaWiki->initialize(Object(OutputPage),
Object(Article), Object(Title), Object(User),
Object(WebRequest))
#6 {main}


Does anyone know what this means? Please keep in mind that I have a somewhat limited knowledge of code…

Thank you.