Greymatter problem

apps

#1

Hi all,
I’m using Greymatter 1.2d since last august and it always
worked well. Today I’ve been informed by a reader of my
blog that the comment post/preview function doesn’t work
anymore. I tested it and the problem exists.
After filling the form and pressing ‘submit’ or
’preview’ the server stops for almost 30 seconds, then
the program show ‘no valid data’, a message that usually is
showed when no input have been inserted.

I experimented a bit and discovered that:

  1. if I do not fill any field (name/mail/comment)
    the ‘no valid data’ is showed immediatly, as it
    should be.

  2. a simple cgi program that does the same things of
    initial lines of gm-comments.cgi (read data from stdin,
    and parse it with regex) works flawlessy.

  3. another cgi script based on the exact initial lines of
    gm-comment.cgi works well too.

Any idea of what can be happened?
I contacted support but since it may be a greymatter iussue
(but once again, it worked for months and I didn’t change
anything) I prefer to ask here too.

Note that the gm-comments.cgi module expects a form to be
sent thru POST method.

Thanks in advance if someone can help…

UPDATE:
I tried the ‘diagnostic and repair’ option and all
come back working correctly. Still I’m curious to know
what can be happened. Any idea?