Got XML file donwloads when I go to site, now getting just a blank page

wordpress

#1

After I updated WP Super Cache to 1.5.8, I started getting a new browser window open up with a mysterious yellow page about an XML parsing error. It downloads a file with a different name each time such as rQbag_p0.xml whenever I tried to go to any other place on my site.

The first page error said:
XML Parsing Error: not well-formed
Location: file:///Users/xxxxxx/Downloads/Fjo_hdyy.xml
Line Number 117, Column 33:


---------------------------------------^

Lately, I’ve been getting
XML Parsing Error: unclosed token
Location: file:///Users/xxxxxx/Downloads/+JU1P0qe.xml
Line Number 1, Column 1:<?php
^
The downloaded file contains the following:
<?php
/**
* Front to the WordPress application. This file doesn’t do anything, but loads
* wp-blog-header.php which does and tells WordPress to load the theme.
*
* @package WordPress
*/

/**
 * Tells WordPress to load the WordPress theme and output it.
 *
 * @var bool
 */
define('WP_USE_THEMES', true);

/** Loads the WordPress Environment and Template */
require( dirname( __FILE__ ) . '/wp-blog-header.php' );

`

I reported this to Abuse & Security and they ran a check to look for malicious code but didn’t find anything. They suggested the problem might be in my .htaccess file. I renamed the existing one to .htaccess.OFF and uploaded the WordPress generic htaccess file.
# BEGIN WordPress <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule> # END WordPress

Now I no longer get an XML file downloaded but now I only get a blank page when I try to go to the website.

Then they suggested that the theme may be corrupted and to change to twentysixteen and see if that cures the problem. However, because I only get a blank page, I couldn’t get to the dashboard to switch the theme. Then I was told to do that by editing the options table in the database to change the template and stylesheet to twentysixteen. I did that but I still get a blank page when I go to the site. I’ve cleared cache and history and tried it on three different browsers with the same blank page result.

I’ve tried editing my htaccess file to block various referrers and user agents but when I upload it, I start getting the XML file download. I go back to the generic WordPress htaccess file and back to getting just the blank page.

It doesn’t seem to be a theme problem or the htaccess file. I manually replaced the WordPress core with the latest 4.8.3 and manually deleted all plugins and uploaded fresh downloaded plugins. None of that helped.
I am using the same theme, child theme, and .htaccess file on three other sites on the domain and they are not having this problem.

My site has been down for four days now trying to get this solved.

Does anyone have any other ideas about why this has happened or how to fix it? The site URL is https://events.stcwdc.org

The other URLs that are working are
https://wdcb.stcwdc.org
https://competition.stcwdc.org
https://jobs.stcwdc.org

Thanks for any help you can give me.


#2

I would just restore a backup of the database and files… Did you take a backup before installing WPSuper Cache?


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.