Got Trac working, but now PROPFIND errors via SVN


#1

I already had a SVN project up and running at svn.mydomain.com/myproject (installed from the DH Panel) and could commit to it, checkout, browse, etc.

I then setup Trac via the DreamTracInstall script from the wiki and could use that to browse the source of my project repository. However, I could no longer browse Subversion directly. I modified the Rewrite rules in my .htaccess file so that requests to the Subversion project folder were no longer passed through Trac’s index.fcgi and I could then browse the repository directly in my web browser again.

However, I still can’t commit or browse the remote repository from my PC via the SVN command line utility or TortoiseSVN. Both complain about PROPFIND errors: svn: PROPFIND request failed on '/' svn: PROPFIND of '/': 200 Ok (http://svn.mydomain.com) and my apache access.log is filled with: 111.222.333.444 - - [28/Sep/2007:07:53:38 -0700] "PROPFIND /myproject/trunk HTTP/1.1" 401 3547 "-" "SVN/1.4.5 (r25188) neon/0.26.3" 111.222.333.444 - - [28/Sep/2007:07:53:38 -0700] "PROPFIND /myproject HTTP/1.1" 401 3491 "-" "SVN/1.4.5 (r25188) neon/0.26.3" 111.222.333.444 - - [28/Sep/2007:07:53:39 -0700] "PROPFIND / HTTP/1.1" 200 6095"-" "SVN/1.4.5 (r25188) neon/0.26.3"There is nothing in the error.log that relates to the requests.

I’m connected to the remote repository using a URL like http://svn.mydomain.com/myproject/trunk. Trac is installed at http://svn.mydomain.com/

Trac works fine and I can use it’s built-in Browse functionality to view the repository files. And as I said above, I can again look at the latest changeset through subversion directly by going to http://svn.mydomain.com/myproject/, but trying to do anything against the repository remotely is failing.

The last thing I tried was adding another RewriteCond to the htaccess file that would ignore any requests using the methods PROPFIND or OPTIONS, and I also tried the reverse of ignoring any requests that weren’t using GET, POST or HEAD methods. Neither method resolved the problem.


#2

I just got this error too. Were you able to figure out how to get around it?

In my case, I lost the ability to connect to my SVN repository using TortoiseSVN after installing Drupal to the root directory of the domain it’s listed under.

Thanks in advance, if anyone has an answer…