Google Pagespeed causes WordPress page rendering problem

wordpress

#1

This isn’t so much a question but rather more of an answer. For over a year I had a problem on my WordPress site http://www.hawaii247.com where if a user clicked on an image to directly view the image file and hit the ‘back’ button on their browser the webpage layout would be askew. Widgets in the wrong places, thumbnail images in the wrong place. I couldn’t quite figure it out.

Finally I thought it might be Google’s Pagespeed which I had turned-on for the domain via the Web Panel. I turned it off and now pages revisited via the ‘back button’ in a browser render perfect.

So if you’re encountering the same problem, try turning Pagespeed off for your domain.


#2

There are some issues with the display of images in mod_pagespeed.

You can take advantage of the rest of its capabilities, and avoid the problem, by inserting this into your site’s .htaccess file:

ModPagespeedDisableFilters rewrite_images

The other issue is that the version DreamHost uses is about a year old. Future versions of Google’s add-on will have this set by default, according to the developers.


#3

Nope, that didn’t work. It’s not an image problem I think it’s some kind of javascript problem as it has to do with the widgets being out of place. Leaving it turned-off appears to be fine with no apparently slowdown since I have caching enabled on my site.


#4

You may want to join up the mod_pagespeed mailing list (see mod-pagespeed-discuss@googlegroups.com), and you can talk over your issue with the utility’s developers. They helped me with the problem I discussed here.