Google apps CNAME not working


#1

I used the checkbox in the control panel to enable the calendar.camerata.com and sites.camerata.com and mail.camerata.com type CNAMEs to point to my google apps account. I also run email through google with an MX record and it seems to work just fine.

The CNAMEs did get created. From my desktop if I do

$ host calendar.camerata.com

I get the answer

calendar.camerata.com is an alias for ghs.google.com.
ghs.google.com is an alias for ghs.l.google.com.
ghs.l.google.com has address 66.249.81.121

which is correct, but when I try to visit

http://calendar.camerata.com/

I get a 404 URL.

Should I just wait for the CNAMEs to propogate to google’s DNS servers or something or do I have to change something in my google apps config to tell google to check the domain name that is being requested and give me the correct URL?

It seems like I could just create redirects using the dreamhost control panel to go to the correct url’s at google instead of using these CNAMEs, but I would like for it to be seamless.


#2

At http://calendar.camerata.com/

I see the Google page

Welcome to Washington Men’s Camerata

Maybe you need to refresh your browser cache or perhaps my DNS server was updated quicker than yours.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK! :@

Act on my advice at your own risk!


#3

Great, thanks!

After posting I went to google apps config and started clicking on options. I found that I could go to the Service Settings menu, then click Calendar, then if I clicked on the option to “Change URL” it all started to make sense. When I clicked that for calendar they also included a link to “Change URLs for all domain services” which I did, and it now works. I didn’t see that in the dreamhost help or in the google help, so maybe it can get added to the wiki at some point.


#4

You can change the URLs for the Apps at each point.
The website needs to have a CNAME added to the DreamHost dns if you want to add a different URL for the website.
Sometimes I have noticed you have to click and save back and forth between your own URL and the default Google URL to make it stick.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK! :@

Act on my advice at your own risk!


#5

I think that is a great idea, and one of the best things about the DreamHost wiki is that anyone is welcome to edit! :wink:

Feel free to jump in and add what you think is helpful; we need all the contributers we can get! :slight_smile:

–rlparker


#6

norm, many thanks

can you walk me through cleaning up my google sites url via DNS? i tried many times to do it but everything got ugly.

the upshot is i want
http://sites.google.com/a/cinemapurgatorio.com/cinema-purgatorio/Home

to become, simply,
http://cinemapurgatorio.com/Home

when i came the closest, i was redirect alternately to a general google generated 404 and a google pages generated 404. argh —

many thanks. i wish that this conversion for those of us who jumped on google sites out of the gate (before DH implemented its one click) would be easier.


#7

Log in to your start page for Google Apps which probably statrs with http://start

When you are on the ‘dashboard’ page (select dashboard tab if required) you will see towards the bottom left a link ‘Sites beta’ with the link
http://sites.google.com/a/cinemapurgatorio.com/cinema-purgatorio/Home

Click the blue ‘Sites’ link and you will go to the Sites Settings page.

Towards the top of this page you will see:-

[code]Web address

Your users can access Sites at:

http://sites.google.com/a/cinemapurgatorio.com/ [color=#0000CC] Change URL [/color]

[/code]Click the ‘Change URL’ and then use the radio button to select the custom setting option.

Enter the URL you require and save changes.

You will have to make sure you have a CNAME setting for the address you wish to use.

These are set up via the DreamHost Control Panel under the ‘manage domains’ page.

On the domains page is a small DNS link to take you to the settings page.

Here you enter the host name in the first box, select CNAME from the drop down and then enter ghs.google.com in the value box.

Then click Add Record Now.


The problem you may have is that you may have added http://cinemapurgatorio.com/ before Google apps was introduced and you will see that it has an A record in the unchangeable part of the DreamHost DNS section. If you added the Domain and added with the Google Apps box clicked when you added it in for full hosting then you should already have an A record pointing to Google for your domain name.

What I tend to do is create a new host (sub-domain) purely for Google Apps where the domain has already been added in to DreamHosts DNS.

So I have something like (where the domain is example.com)

apps.example.com

This then has the various Google pages set by me via the ‘dashboard’ to:-

start.apps.example.com (start page)
sites.apps.example.com (sites)
web.apps.example.com (web site created with the website builder)

and so on…

You can do this and then set up your page

http://cinemapurgatorio.com/Home

to redirect to

http://sites.cinemapurgatorio.com/Home

if you wish.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK! :@

Act on my advice at your own risk!


#8

I just setup Google Apps for a new domain and when docs.mydomain.tld returned a Google 404 I started looking for help. The quote above was the solution. Thanks!

I wish this info were available in the DH dashboard Domain setup where we check to add Google Apps. That would have saved me a lot of time.