Go-Pear Install


#1

I am attempting to install a PEAR Channel on one of my domains. Unfortunately, I am new to BASH. This process requires PHP5 (which I have setup using the DH control panel) and a local installation of PEAR. In order to install PEAR I need to execute the following command in my BASH session:

$ /usr/local/php5/bin/php go-pear.phar

Unfortunately this command seems to hang!

I tried downloading the .phar file to my Windows box and did the same thing and all worked well.

I checked the version of my /usr/local/php5/bin/php and it produces v5.1.2 which is cool.

So anyone have any ideas on how I can proceed with this effort?

Also I would appreciate any pointers on how to setup a local copy of PEAR on a DH domain from someone who has done so using the DH PHP5 install (NOT YOUR OWN PHP5 Installation).

Thanks.


#2

The PEAR site has instructions for installing PEAR in a shared hosting environment:
Installation of a local PEAR copy on a shared host

I’ve done something similar and it works fine on a Dreamhost server.


If you want useful replies, ask smart questions.


#3

Got your PM on this. Sorry I couldn’t help you to much here. I have my own copy of PHP.

However, as kchrist pointed out, PEAR has a full step-by-step instruction on how to setup PEAR to use your personal archive.


yerba# rm -rf /etc
yerba#


#4

Well kchrist I tried your approach. Unfortunately I get the following Error after successfully creating a .pearrc using SSH:

[baht]$ pear install -o PEAR
Did not download optional dependencies: pear/XML_RPC, use --alldeps to download automatically
Skipping package “pear/PEAR”, already installed as version 1.4.6
downloading Archive_Tar-1.3.1.tgz …
Starting to download Archive_Tar-1.3.1.tgz (15,102 bytes)
…done: 15,102 bytes
downloading Console_Getopt-1.2.tgz …
Starting to download Console_Getopt-1.2.tgz (3,370 bytes)
…done: 3,370 bytes
ERROR: failed to write /usr/local/lib/php/Console/.tmpGetopt.php
ERROR: failed to write /usr/local/lib/php/Archive/.tmpTar.php
[baht]$ which php
/usr/local/bin/php
[baht]$

Any ideas?