Gmail: I can send but not receive


#1

I changed my “nameserver 1 & 2” to ns1.ipage.com to host my domain. I already had gmail configured and working properly before this. My splash page is now up: ChildsPlayMedia.net.

After the name change gmail(martin@childsplaymedia.net via gmail) stopped sending/receiving. I started up the “MX” email service, logged into my gmail and gave it over 24 hrs to reflect. I can now send emails but if I reply they never get back to martin@childsplaymedia.net.

Any advice? I’m still a newbie to this hole experience and am surprised I got the gmail up and running with my domain(before hosting & server name change) to begin with.

Thanks in advance for any help on alleviating my problem.

KRAWSH


#2

Since you’ve changed your nameservers to ipage, we’re no longer in control of the MX records, which control how mail to your domain is routed. You’ll need to make sure that GMail is set up as your mail server on the ipage end of things — since I’m not familiar with their service, though, I can’t provide any exact directions.


#3

Andrew, hi, I’m having the same problem, but mine is a bit simpler and maybe you can give me the proper answer. I have my gmail accounts set up and they can send, but they do not receive any email. I am hosting through dreamhost and have used dreamhost’s option to use gmail which I see automatically sets the mx records but it still will not take. The only thing I can think of is that I have set up this domain to forward to another one when the page loads, but I don’t think that should affect email. What am I doing wrong? I have verified the domain with gmail, I have updated dreamhost as of yesterday afternoon to the default gmail mx records. Thanks for any thoughts you have.

-Krstrobe


#4

The MX records are strictly to set up your site to use Gmail. You still have to configure your email client with your account, or use the Gmail Web client. Have you done that?


#5

yes, I have the gmail web client set up and running but no incoming emails. I changed the MX records so I could use gmail. I have done this before but there appears to be a disconnect in this case. My google cpanel tells me it’s still updating the MX records, that they are propagating, so I may need to just wait… it’s already been 24 hours… should it be taking this long? Thanks for your quick reply :slight_smile:


#6

It may be an issue with Google. But, yes, it should be resolved far faster than that.

Unfortunately, getting assistance is not going to be easy. Google won’t provide direct support, other than in their message boards, unless you opt for the business version of Google Apps. I don’t think DreamHost officially supports these setups, even though they provide the tools.


#7

ok, thanks for the information, Gene. I think I’ll try resetting the MX records in dreamhost and not just keep waiting. I haven’t had it take long in the past but I wasn’t sure if something just may need more time.


#8

I moved four of my domains to Gmail some time back. Two used the free Google Apps setup; two used the business version. In all case, it was no more than an hour or so before email started coming in. But those things aren’t always predictable.


#9

Ok here’s hoping it starts receiving. Do you think the domain forwarding has anything to do with it?


#10

Ouch. Well, I do think that’s maybe an issue. You should ask.


#11

alright, thanks again!


#12

well no luck yet, I’ve tried taking off the gmail MX records in dreamhost and then setting them again and that didn’t work. I am afraid to delete the account with google in case I can’t recreate it! Maybe I will try that though…


#13

Hi Krstrobe…did you ever get this resolved? I’m having the same problem, although I haven’t waiting for 24hrs?


#14

Yes, I have all the Gmails working now. I didn’t have to wait 24 hours or really even one… It was pretty quick. The issue was that I had set one domain to forward to another domain and the domain that I was forwarding from couldn’t have URL forwarding on it and still have Gmail work. I had to just create a page with the link on it asking people to click to go to the other website. While forwarding from that domain was enabled, all the Gmail accounts associated with that domain were broken. Does that make sense? I hope I’m being clear enough.


#15

You made perfect sense! I just had an ‘ah ha’ moment and realised that I didn’t create the mx records with the name ‘@’. I have just deleted the records I first created and recreated them all with the name ‘@’ and instantly the light has been switched on and the gmail is working perfectly! Many thanks for your reply though!


#16

Hi folks,
I am not following this very well. I have Gmail working great sending receiving from email accounts properly. What is this ‘@’ solution? I do not understand. I could use an ‘aha’ moment too lol!

Problem:
I am using Drupal which generates email in PHP - I am not receiving the emails from the contact form http://kentlakefalconfootball.com/contact

I obviously have some setup issue as the auto response is working, sending to the sender, but the sender’s message is not making it through.

To test send a message from http://kentlakefalconfootball.com/contact - category Website Feedback. You should get an auto response within seconds, but I won’t get the message.

I entered all of the MX records given by Google Apps (mail calendar docs etc) everything works great except the emails from the contact form. Unfortunately I can only flush DNS every 12 hours so this is a painstaking process, I get one try every 12 hours to try something - any help would be greatly appreciated.

Thank you!!!
~ Jim