Getting mail to not be classified as spam


#1

I occasionally send out bulk mail from my site to customers. I had increasing problems using shared hosting, since other peoples’ sites would get hacked, making it harder for my legitimate mail to avoid spam filters. I finally moved to a VPS recently based on a recommendation from Dreamhost, but if anything the problem is worse now. In particular everything going to Gmail gets auto-flagged as spam, so I spent some time going through Google’s recommendations for avoiding the spam filter, but it doesn’t seem to have helped. I see this in the header:

Received-SPF: softfail (google.com: domain of transitioning [email address] does not designate [ip address] as permitted sender) client-ip=[ip address];
Authentication-Results: mx.google.com;
spf=softfail (google.com: domain of transitioning [email address] does not designate [ip address] as permitted sender) smtp.mail=[email address]

With [email address] and [ip address] being the actual addresses, of course. So, does anyone know if there’s something I should be configuring somewhere that might help?

–Eric


#2

Are you saying someone at DreamHost told you that VPS would help with mail issues?


#3

Yes:

[quote]Thank you for your email. I am sorry for the trouble you are having with
your email being sent off your web server. Currently one of our mail
relays which relays email off the server is backed up with large mail
queue. This is causing email sent off the server to be delayed. My admin
team is working hard to bringing the queue load down, so that mail can
flow a lot faster. Once the issue is resolved you will start to see mail
move in to your mailbox.

Also our VPS service allows email sent off the server skip the relay
process and send directly off the server. So you could avoid these types
of delays. If you would like more information on the VPS service you can
read about this more here;

http://dreamhost.com/servers/vps/

I do apologize if this has caused any inconvenience and thank you for
your patience. If you have any further questions or concerns, don’t
hesitate to email me back.[/quote]

–Eric


#4

If the original issue was mail being designated as spam (rather than delayed mail) then you’re being swindled.

Those softfails are common as muck. The auto spam designation is more likely to be a blacklisting or incorrect mail header settings problem if your mail is handled by DreamHost Mail. If you use GMail (Google Apps) then you could try setting MX, DKIM and SPF records appropriately. Search the forum here for keywords like “email From:” and “DKIM” and “SPF Record” to see if anything there gives you some ideas of what you could try.


#5

To be fair, the issue I had with mail actually being bounced because of sharing a blacklisted IP address seems to be gone. Also, having the 200 mails/hour limit lifted is worth the $5/month extra, so if it’s a swindle I don’t mind too much. :wink: Thanks for the suggestions; I’ll look into those.

–Eric


#6

If sending out over 200 mails an hour then I’d definitely be ensuring all the above records are in order. Something else to keep in mind is that end users might create problems if enough of them mark your mails as Spam at the receiving center instead of unsubscribing or opting out of receiving any automated mail.

Have you considered an Announcement Mailing List ?


#7

I had looked at the Announcement Mailing List when I first started, but it doesn’t do what I need. Anyway, it looks like getting the SPF record set up correctly fixed the problem. It seems DKIM is set up automatically.

One possible issue is that according to this SPF validator, the SPF record should also be published as type SPF, but there’s no option in the Dreamhost control panel to choose SPF as a type, only TXT (and some others that aren’t relevant here).

But anyway, I’m not getting the softfail from Gmail anymore, so I guess it’s OK for now. (Ironically, in the midst of all this, I had an email from Dreamhost itself tossed in my Gmail spam folder, supposedly for “phishing”, even though it was just a payment receipt. The false positives are maybe getting a bit out of control…)

–Eric