Getting http errors when uploading to my wp site


#1

Hello to all. I have a word press site and i have it set to except files of 1024 mb and smaller. That goes well until i try and upload a 156 mb file. I get http errors but i can’t see what they are when i try and do this. I’m trying to upload using the easy digital downloads plugin and files that are small work fine and dandy but i want to get my bundle up there not just my individual files.

Any thoughts? all it gives is http error but does not say what it is. I’m thinking it might be a time out but i don’t want o fiddle with that as i am on a shared server and all was well for a while. Should i just wait until tomorrow morning and try again? maybe a lot of people are uploading this late at night?

take care.
P.S I put this here in case this is a dream host issue not a wp issue.

Take care all and happy monday.


#2

Are you sure that some of the plugins that you uploaded and went through are not causing this? Some plugins can have an effect on wordpress so you might want to start trouble shooting on that first. I’ve been able to upload/download larger wordpress files and there’s no problem about it.


#3

This is uploading to the media library. I often have trouble with zip files and large ish mp3 files and stuff that I sell. I even tried importing it using add from server with no luck. Yes disabling all plugins except for that one and even just straight up uploading to the library caused this. I notice that it goes away after a while so it makes me thing either my bandwidth is capped or dream host only allows a certain number of uploads or large files per day even though I have a lot of space left. lol! and no ftp did not fail. I was going at a solid 8 mbps. when I tested the upload to see fi it would work that way, which it didn’t. the plugin uploaded in to a protected directory to prevent hot linking which is what I want for these files.

Iv’e had trouble before with huge uploaded and no plugins and straight up uploading via http to the media library but the issue seems to like I said go away after a few days and not come back for months until I upload something big like a zip file.

Take care.


#4

So … that http error is basically WP saying “Aaaaaugh!” It’s my second least favorite error out there right now.

Possible causes:

  • Image cannot be parsed by our image compression/resixer (imagemagick normally, sometimes GD), so it can’t generate thumbnails
  • No room in /tmp/ for your files to be processed
  • Plugin/theme conflicts
  • Something else

If you’re having it with LARGE files exclusively, then it’s probably the tmp folder. You can put in a ticket and ask us to check how full it is, but if it’s not very full and you’re on Shared, you’re out of luck :confused: If you’re on VPS/Dedi there are things we can do to mitigate it, but in general, it’s an issue with the tmp folder.

If you’re only having this when you try to upload a lot of moderately sized images, upload them in smaller chunks. Same reason :confused:


#5

I can’t do that. It’s 1 zip file and I just tried again and got this no more info then what I"m about to paste here.

HTTP error.

and I did not upload any huge things today at all. Again it works using ftp but the plugin won’t protect the link, unless I’m uploading it from the library fraim when it comes time to add files. I have a path from my ftp directory but I don’t want users to guess the link hence why i WANT to upload the file this way. What logs can I view if any that will lead me toward a solution, besides pulling out my hair, or what I have left of my hair anyway. smiles

Take care and be blessed.