Get rid of extra cgi-system/php.cgi in url?


#1

Been trying to get my site running for a week now and realized the problem was that some of the things had an extra “cgi-system/php.cgi” right after the url (site name). Like it would go to “www.mysite.com/cgi-system/php.cgiray/otherfiles…” instead of going to “www.mysite.com/ray/otherfiles…”

I changed the php from 4 to 5 but still same errors.

Tried using this but no help:
http://discussion.dreamhost.com/showflat.pl?Cat=0&Board=forum_programming&Number=63238&page=&view=&sb=&o=&vc=1

I installed Dolphin on my site. I also installed it on another host (netfirms) with php 4 and it works perfectly on it but not on dreamhost (i’m not dreaming yet…). I tried changing the php versions…and still nothing.

Anybody know how to fix this?

Oh yeah, i’m on the agamemnon machine/server.


#2

The issue you describe has nothing to do with which version of PHP you are running, or with the PHP configuration issues discussed in that other forum post to which you linked.

The problem appears to be that your applications is expecting to be running PHP as mod_php instead of running PHP-CGI (which is what is installed at DreamHost), and has used an environment variable that returns a value that was not expected by the programmer.

Is Netfirms running mod_php? Have you compared the phpinfo() output from the Netfirms account with the phpinfo() output from your DreamHost account?

What application are you running?

–rlparker


#3

I did a little more research for you (assuming that your application is Dolphin by Boonex), and I think I found you some useful additional information.

Per the “Requirements” section of the Dolphin manual:

  1. DreamHost has allow_url_fopen set to OFF
    by default, and this is for security reasons.

2)domxml is enabled by default only in the DreamHost default PHP4 installation; it is not installed/enabled in the default PHP5. (see the PHP manual for more info - http://us3.php.net/manual/en/ref.domxml.php)

  1. Additionally, that link in that Dolphin “requirements” page takes you to a post on the Boonex blog where it is strongly “suggested” that the “Ray” component needs “root” access to run and “SSH superuser access”. You will not have such access on a DreamHost shared (or DreamHost PS) server, but it may well be that running PHP-CGI under suEXEC will allow you to work around that (the blog author gives no detail on his claim).

That all suggest to me that you will need to either do some php.ini modifications and or some custom PHP installing to assemble the proper environment (and doing it with/for PHP4 might be easiest).

All that said, Google pointed me to a site where there author reports having installed it (and having successfully upgraded it) on Dreamhost so you might want to check that out. While he doesn’t give any technical details of his environmet set up (is he using PHP4 or PHP5, and how did he handle the allow_url_fopen issue?), he provides a step by step tutorial and almost 10 minutes worth of flash movies and screencasts).

http://www.sridhareena.com/2007/11/09/how-to-install-boonex-dolphin-run-your-own-social-community-site/
http://www.sridhareena.com/2007/11/13/how-to-upgrade-dolphin-from-600002-to-600003/

It seems in his “upgrage how-to”, he makes a change that looks like it might (will probably) fix your path problem . This might depend upon what version of Dolphin you are working with, as he did not indicate this change was required for his initial installation of version 6.0.0002, but includes in his instructions for upgrading to version 6.0.0003.

Edit inc/header.inc.php - find:

Add the following below after it:

[quote] "$aUrl = parse_url( $site[‘url’] );
if( isset($_SERVER[‘HTTP_HOST’]) and $_SERVER[‘HTTP_HOST’] != $aUrl[‘host’] ) {
header( “Location:http://{$aUrl[‘host’]}{$_SERVER[‘REQUEST_URI’]}” );
exit;
}[/quote]
Note that for all of Dolphin’s parts to work, you will need to install a media server (which you cannot do on a shared server DreamHost account). It also seems to me that the overall system requirements and resultant CPU/memory load might well make this application (if it had any number of visitors at all) not really appropriate for a shared server environment.

Online video processing can be very resource intensive and often a dedicated server/VPS (maybe DreamHost PS) is what is required to run this application with reasonable performance. I’ll bet the author on the site I linked above could give you some feedback on that. :slight_smile:

–rlparker