Geeklog & RSS

apps

#1

Trying to get an RSS feed into a block of my Geeklog site… I entered in the RSS feed into the block, and on display it fails, and enters the following into the error.log:

“Geeklog can not reach the feed at (blah blah)”

(blah added on my part)… Doing some research on this error on geeklog’s forums gave me the answer; specifically the following text needs to be put in the php.ini:

“allow_url_fopen=on”

which I’m assuming its currently set to off… I’m wondering if any of you php experts know if this can be changed per directory in an .htaccess file, or can it only be set in the global php.ini?? I’m getting conflicting reports on whether it will work in .htaccess or not, depending on the version of php being used… Since the php.ini is a global file (on shared hosting) I don’t know if DH would be willing to make the change… Any other suggestions would be welcome…


#2

As of PHP 4.3.4, it can only be changed in the system php.ini file. It’s enabled by default, so if it’s now disabled, it was intentional. As this is often disabled as a security measure, I suspect DH will not be willing to enable it.


#3

I assumed such, since I knew it was a security issue… However, as for the version, running “php --version” from the command line shows that PHP 4.3.10 is running on my server; but I still agree that it is a hole that should remain closed…

Edit: apparently it already is flagged “on” on the server; I put a test script on my site with only “phpinfo();” and the allow_url_fopen is “on”, on both local and master configs… I’m going to have to do more research with geeklog on this…