Gallery2: Error with file operation

apps

#1

I’ve got a large Gallery2 installation with around 7000 images in full resolution which worked fine until today. It all started when I got errors viewing random images, one image would work and the next one would keep on loading and then Gallery would display an error.

Further testing seems to point in the direction that all file operations are suddenly producing errors, trying to delete images/albums and adding images/albums all fails.

The errors always look like this:

[code]Error (ERROR_LOCK_TIMEOUT) : /home/MY_USERNAME/data/g2data-bilder/locks/31366

  • in modules/core/classes/FlockLockSystem.class at line 109 (GalleryCoreApi::error)
  • in modules/core/classes/GalleryLockSystem.class at line 147 (FlockLockSystem::_acquireLock)
  • in modules/core/classes/helpers/GalleryLockHelper_simple.class at line 176 (GalleryLockSystem::acquireWriteLock)
  • in modules/core/classes/GalleryCoreApi.class at line 2193 (GalleryLockHelper_simple::acquireWriteLock)
  • in modules/core/classes/helpers/GalleryEntityHelper_medium.class at line 42 (GalleryCoreApi::acquireWriteLock)
  • in modules/core/classes/GalleryCoreApi.class at line 2271 (GalleryEntityHelper_medium::deleteEntityById)
  • in modules/core/ItemDelete.inc at line 79 (GalleryCoreApi::deleteEntityById)
  • in main.php at line 231 (ItemDeleteController::handleRequest)
  • in main.php at line 94
  • in main.php at line 83
    [/code]I have already tried rebuilding the database using a two day old backup (when everything was still running fine) but it didn’t help. Also deleting all caches didn’t help (or also produces errors).

I thought DH might have moved me to a new filer, but that’s also not the case.

Any ideas?

Update: I just noticed that it also affects my two other completely independent Gallery installations.

Jan

Promo-Code: [color=#CC0000]SAVEMONEY97[/color] - Save [color=#CC0000]$97[/color] on your first year of hosting.
Get more promo codes here


#2

The same exact thing happened to me today. Mine was a fresh install, so it isn’t that bad. However, I recall getting an error exactly like yours (minus username,etc).

I could not move or delete files either.

Then it magically went away and all was fine.


USE PROMO: 97DH For $97 off!


#3

I have figured it out, you have to go into the general settings and then go to “Locking System” and set it to “Database”. That should resolve the problem. Gallery has a problem with the filers being connected via NFS.

Jan

Promo-Code: [color=#CC0000]SAVEMONEY97[/color] - Save [color=#CC0000]$97[/color] on your first year of hosting.
Get more promo codes here


#4

Thanks.


USE PROMO: 97DH For $97 off!