Gallery2 and ImageMagick

apps

#1

Installing and configuring Gallery, I checked this forum and found that ImageMagick is in /usr/bin but when I tried to rotate an image (I’m not sure whether this would have been done by ImageMagick or another package) I got an uninformative error page. Went back to the forum, then logged in ssh and whereis ImageMagick comes up only with a zipped man page.

Has DH removed ImageMagick?

Also, with that image that I wanted to rotate, anything I try to do with it - even delete - now gives me that error. Can anyone suggest how to recover from that?

For now, I’ve installed netpbm and deactivated ImageMagick. At this stage, I’ve no idea which functions are done by which graphics tool.


#2

Have you referred wiki http://wiki.dreamhost.com/index.php/Image_Magick?

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color].


#3

[quote]Have you referred wiki http://wiki.dreamhost.com/index.php/Image_Magick?

[/quote]

I have now :slight_smile:

Thanks. I think I now understand what I was reading in some of the threads I found earlier - that ImageMagick installs a set of tools and I should have looked for these rather than IM.


#4

now I’ve cleared up that the problem is not due to absence of ImageMagick, I’ve taken another look at the error message, and it’s not 100% true that it’s uninformative, as it refers me to the server error log. Here’s the error message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@gallery.beadsandweeds.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

As for the error log, it’s basically two items repeated: the error

[quote]… Premature end of script headers: php5.cgi …

[/quote]

and the missing 500 page:

[quote]File does not exist: /home/ … /internal_error.html

[/quote]

I didn’t install the Gallery debugging module as I doubted my ability to make use of it!


#5

somebody had the same Internal Error before.

I’m not sure whether the cause is the same, but here is a solution to refer Internal Server Error

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color].


#6

Thanks again!

I ran top and there weren’t any php processes running but I think you were right and they had at last timed out, as I went back to the gallery and deleted the offending item without problem. Moreover I went and rotated another image a few times, everything working smoothly. As I have, in the meantime, reactivated ImageMagick, my configuration is pretty much as it was at the time of the original error except that I’ve added netpbm (which is lowest priority in the settings). So I’m as clueless as ever as to the original problem, but happy that things are now working.


#7

Although I did not help too much (you figure out everything by yourself :P), I’m still glad that you get everything working

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color].