Gallery thumbnails

apps

#1

I have the PHP Web application Gallery installed and I’m having issues with the GD Library image resizing when I attempt to upload pictures.

I try to upload a picture and it tells me it could not create a
thumbnail.

I have a friend who uses Dreamhost who installed this program for me. He says that he uploaded a copy of my Gallery onto his web server and he couldn’t get the pictures to upload either.

I have a ticket into support, and so far they have told me to check my paths. I have 4 albums and have been successfully uploading photos before this problem happened, and I haven’t updated the Gallery or made changes to the config…so I’m not sure how it could have changed.

Hoping someone here can shed some light on my problem. Thanks!


#2

What Graphics suite you using in Gallery (and I presume you are talking about Gallery 1 here)??

You should be using ImageMagic, NetPBM on DH is out of date.


#3

Not trying to beat a dead horse here… but I’m having the same problem.

I think it is steming from an incorrect path the ImageMagick. I have specified ‘usr/bin/X11/convert’ (without the quotes). Am I missing something?

(Tried coppermine, it’s ok, but I kinda like the layout with Gallery - oh, and I’m using 1.5)

Any help is appreciated.


#4

Sweet jumping jeez…

I fixed my problem by (either) changing the path to ImageMagick to just usr/bin/ or changing the permissions on the .htaccess and config.php files to 644 before trying to modify the settings. I’m not sure which of these did the trick, as I did both of them at the same time, but now I can upload images and the thumbnails are created, without any errors!

Imagine that… reading the KBase actually (kinda) helps! :slight_smile:


#5

You got to use imagemagick in either G1 or G2 as netpbm is way out of date and incompatible with G1/G2.

Mind you imagemagick is also way out of date but not as badly yet…

Yes the imagemagick path is /usr/bin and changing your .htaccess / config.php to 644 should not have been required as apache has full read rights by default…


WP/Gallery2 Integration Community -> http://wpg2.ozgreg.com/