Gallery one click install upgrade problem


#1

After upgrading to the newest 1-click install for gallery I get an error when trying to use the upload applet. It is when you use gallery remote or the java applet you get an error message saying that “jpegtran is not installed or mis-configured”. Is this something I need to manually configure now? I know the older 1-click install had the remote and applet working ok. Was this just an oversite when setting up the new 1-click install.


#2

Maybe it’s time to go through your modules and their settings. For the Graphics Toolkits, you do a test in each one’s configuration screen.

-Scott


#3

Their is only 1 toolkit that gives any sort of grief when testing and that is basically that it can get stuck in an infinite loop somehow. From what I gather the toolkits don’t play any part in the upload applet.


#4

The upload applet (in my configuration) uses a graphics toolkit to adjust file and image size. And as I think of this, Gallery has to use some sort of graphics toolkit to create the thumbnail.

The graphics toolkit modules I have installed are Gd, ImageMagick and NetBPM. Which one’s giving you grief, and what are its settings?

-Scott


#5

It appears it might be a problem with ImageMagick but when I run the test it appears ok. It does give me a warning that the version of ImageMagick has a known vunerablity to allow it to loop continuously but everything seems to check out with the test button. Anyway to re-install ImageMagick? (sure I could figure it out but never had to before since it was all part of the one-click install).

Really are not settings for it that I can tell… just the binary directory listing /usr/bin/ and the jpg quality setting which is at 75.


#6

That vulnerability had a footnote that says that under Debian, the vulnerability report is inaccurate. DH runs Debian, so I don’t think that’s a problem.

How about using the Gd toolkit instead?

-Scott


#7

Nope. I have given both other toolkits higher priority but it still has the same problem. Gallery remote makes use of only the ImageMagick toolkit it seems and is having problems. It is either mis-configured or it cannot find it from what I get from the error message. Worked fine when I had the older version of gallery. Might just have to revert back.


#8

I use Gallery Remote, but have ImageMagick installed locally. I’m thinking it’s a problem with your local copy of ImageMagick, if you even have one installed. Since this is my working setup, I don’t know if GR will let you know of a specific problem on the server side, such as a broken graphics toolkit.

-Scott


#9

Hm… Do you use Gallery Remote or the java upload applet? I will try and download the gallery remote app and see how it goes. I know the problem I run into is the java applet.


#10

I have Gallery Remote for the Mac, which is probably written in Java. I thought you said you were using Gallery Remote.

-Scott


#11

Well from what I can tell the upload applet uses some form of gallery remote.