Gallery 2 FFMPEG/Upload Limit

apps

#1

I’ve heard some bad things about Dreamhost support lately, so I decided to post here…
I have a couple of questions, that a day of googling and researching
on Gallery2’s site couldn’t find. How do I make it so people can
upload files larger than 7 mb’s (I’m aiming for 100mb’s for the
videos). On the gallery2 site it said something about the php.ini
files, or an htaccess file. I tried the php.ini file, and I’m testing
that right now by uploading a 35 mb (video) file to the gallery. If this
fails, I’m guessing my next option would be to try the .htaccess file
the only problem with this solution is that I can’t find the .htaccess
file. I got this information from here:
http://codex.gallery2.org/index.php/Gallery2:FAQ#Why_can.27t_I_upload_big_files_ .28over_a_megabyte_or_two.29.3F
I got told on another forum, that I might need the host (dreamhost) to get involved to modify this “.htaccess” thing… Is this true?

My next question is regarding ffmpeg two. As I look at the gallery
ffmpeg test settings it tells me it only supports the following:
video/x-ms-asf
video/x-msvideo
video/quicktime
video/mpeg
video/x-ms-wmv
Well, now I have a binary that has support for alot more codecs, and is designed for dreamhost, but the thing is when I look at that other ffmpeg thread it talks of command lines… Could somebody dumb down this ffmpeg installation process, and tell me how I can make it so it’s in the /usr/bin/ffmpeg file so Gallery would be able to use it.

I hope I posted in the right forum, but if I didn’t post in the right forum please tell me, because I need all the help I can get. Any help, (or even raw effort) will be appreciated.


#2

Don’t you also need ffmpeg-php installed for ffmpeg to work?


#3

The .htaccess file is merely a text file that you write, and place in your directory. Google can help you with what can go in the file.

–rlparker


#4

From the link you posted:

[quote]Also, you can try to override the system-wide default settings in a .htaccess file. Example, add this to your .htaccess file in your gallery2/ folder to set a upload limit of 10 Mega Byte:

php_value post_max_size 10M
php_value upload_max_filesize 10M
[/quote]
.htaccess is just a text file. Create it in the root of your domain and add the stuff from above. Since it starts with a “.” the file may be hidden to you, so make sure you don’t overwrite it if it already exists.

Are these the directions you’ve tried to follow: http://wiki.dreamhost.com/index.php/FFmpeg

If you don’t know how to access the command line or use shell, try here: http://wiki.dreamhost.com/index.php/SSH. In fact, that’s the way I would edit the .htaccess file :wink:

Check out Gordaen’s Knowledge, the blog, and the MR2 page.