Gallery 2.0 Install : file or directory not found

apps

#1

I’m trying to set up Gallery 2.0 using the one-click setup. I got an email saying the installation was successful and giving me directions to finish installing.

Step 1 of the directions says to authenticate by ftp-ing a copy of login.txt to :
/home/.ghost/perihelion//photos/

But when I try to do this I get a “No such file or directory” error.

Has anyone else had this problem?


#2

Is your FTP program giving you the error or the installation?

If it’s the installation, make sure the file is named and formated perfectly. If you didn’t the first time, just download the version they provide instead of creating your own. Also, double-check to be sure the file is in the correct directory: /home/perihelion/domain.com/photos/ Finally, be sure the login.txt file has the correct read/write permissions (644 / rw-r–r--).

If you’re sure you’ve done it all correctly, you can always ask for customer support, or just delete everything and try again.


#3

I am having the same problem when trying to install my own gallery (rather than the one click setup).

One thing that I did notice is that the random number displayed on the Step 1 page is different than the one generated in the link to the login.txt file that they provide you.

I suspect it has something to do with php optimization and random numbers not being properly generated, but that is just a guess. I am going to see if I can find any info on the Gallery forums and failing that try the one click install.


#4

Believe it or not, I read through some of the gallery docs and someone posted that it was working in IE but not in FF for them.

http://gallery.menalto.com/node/50677

I switched to IE and voila it works. Crazy.


#5

The error you describe should give a “the key in login.txt does not match” type of message as opposed to the one originally described in the first post.

I’d recommend using ssh to login to your domain. Change to the proper directory then try this:

vim login.txt
press i
paste the key
press esc
type :wq

Check out Gordaen’s Knowledge, the blog, and the MR2 page.


#6

That is true. The error was “the key in login.txt does not match”.

I was using vi to edit the file through ssh. I tried editing the file with the random number displayed on the install page and also the one that I download from the install page, and neither worked.

The fix for my situation was to use IE for the installation. I don’t know why this worked or what difference it makes to sessions etc, but it worked.


#7

My guess is that you have an extension or something that was affecting the cache? Or perhaps it uses sessions and a setting you have in FF prevented that from happening (like cookies maybe?)?

Be sure to wash off your hands after using IE :wink:

Check out Gordaen’s Knowledge, the blog, and the MR2 page.