Gallery 1.5 Installation Nightmare

apps

#1

Been trying for 2 days with no success…

Working on a Mac OS X. Downloaded Gallery 1.5 tarball, expanded locally and created files and diectories as requested then ftp’d the whole mess to my sites root directory on DH. Try to log into the setup Wizard and get this message:

"Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@[my domain].net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. "

The error log says my .htaccess file not found, but I can see the little bugger right there at the top of the file list.

I tried the shell method of installing (with both Terminal and Fugu) and every command I gave was called an invalid command. So I could create directories and list directories but could not untar the file or enter configure command.

Went back to FTP method and have been trying to find any php file that could be wrong, double checking my chmod’s and have my user settings right (shell turned on, running php-cgi)… I am fresh out of ideas… please help

thanks


#2

Works for me.

  1. Confirmed web service configured to use PHP 5
  2. Upload tarball to ~/software
  3. “cd ~/example.com”
  4. “tar -xvzf ~/software/gallery-1.5.tar.gz”
  5. “cd gallery”
  6. “touch config.php .htaccess”
  7. “mkdir albums”
  8. “chmod 0777 config.php .htaccess albums”
  9. Browse to http://example.com/gallery/setup/index.php
  10. Changed permissions back to 0644 for the files, and 0755 for the directories.

:cool: Perl / MySQL / HTML+CSS


#3

I got as far as getting Gallery’s diagnostic page to run… once with lots of gibberish at top of page (“unexpected line at…” repeat, repeat repeat…) before it actually said “Welcome… you’re OK” and then ran through the config pages and dumped with another server error message. Uploaded the whole meshugas again, put the line about running cgi as php in the .htaccess file. got a nice clean diagnostics page, all properly formatted, telling me what great guy I am and the server is wonderful wih the xception of only have English files (but I can download other languages later…) and my mod_write settings might limit me to 2Mb files (i can live with that… It tells me to proceed… click… another 500 error message.

WTF?

I can quit the browser and restart then get back to that same diagnostic page… but no further.

Grrr.


#4

I feel your pain. I’ve been trying to install gallery 1.5 for 4 days now. My main problem revolves around the session save path. It seems gallery tries to use sessions to carry your data through the config wizard, but running PHP as CGI (php5 also) seems to like to try to store your sessions in /tmp on the server and does not allow you to change this path with the session.save_path keyword in your .htaccess file. Put in a support request on 9/12 and have heard nothing back.

If anyone knows how to fix this, please let me know.
Thanks.


#5

I installed Gallery 1.5 as well. Had most of the same problems, but somehow got it to work. But I didn’t like it, and took my time deleting it, but now it’s not letting me delete an “empty” (i know it’s empty, i just deleted the files!) folder, or the .htaccess file. In fact, I accidently put a .htaccess where I didn’t want it, and I tried to delete it, but it won’t.

Yeah that is my problem that I have to add on, sorry.


#6

Make your life easier and use the new One-Click-Install for Gallery 2.0 < I just tried it and it works flawlessly.


#7

Set your FTP client to show hidden files, then you’ll be able to delete your not-so-empty-empty directory.

-Matttail