Fuse error when installing any package

vps

#1

Hi, I am trying to upgrade Java and install tomcat on VPS but getting below error. When I try any package, I get the same error.

#sudo apt-get install sysstat

Setting up fuse (2.8.6-2ubuntu2) …
Creating fuse device…
mknod: fuse-': Operation not permitted makedev fuse c 10 229 root root 0660: failed chown: cannot access/dev/fuse’: No such file or directory
dpkg: error processing fuse (–configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
fuse
E: Sub-process /usr/bin/dpkg returned an error code (1)


#2

FUSE is not supported on DreamHost PS. “apt-get remove fuse”, as well as any other software packages you have installed which depend upon it.


#3

I dont know how, but probably it was installed as a dependency, apt-get works after I removed fuse, thanks.