FTP'd Images Not Displaying


#1

Hi all,

I’ve not really used my domain for quite a while, but one of my friends needs an image hosted so I offered to stick it online - something that I thought would be a quick and painless process.

As I’ve not had any FTP software for a while, I uploaded the image via the webFTP client at webftp.dreamhost.com and connected to my ftp server at ftp.mydomain.co.uk, and uploaded the image to the /_images/ folder. However, when I tried to browse to www.mydomain.co.uk/_images/image.jpg - it comes up with a 404 error. However, it’s definitely there and I’m aware of the case sensitive issues with the filename and suffix.

Any other images (that have been there 2+ years untouched) all resolve just fine at the same patjh. I’ve now downloaded an FTP client for my mobile, deleted the original image and re-uploaded it from my phone in case it was an issue with the webFTP client - but the same problem.

Permissions are all fine - matching all other images in that folder. And when I FTP directly through a browser, I can get all the way through and resolve the image just fine at the following…
ftp://ftp.mydomain.co.uk/mydomain.co.uk/_images/mariecainbutler.jpg

Just not when I try and browse through the regular way, despite everything else in that folder resolving and displaying just fine.

Any ideas?


#2

Navigate to “manage domains” in the panel, and locate the one in question. The “Web hosting” column should say “Fully Hosted” and then a “user” will be listed. Is that the user you are using when you log into ftp?


#3

Awesome - having same issue and LakeRat suggestion help me. After a few hours of trying I only wish to check the forum sooner.

Thanks for your sharing.


#4

Aha, thanks for this - worked perfectly. I find it a bit bizarre that it’s possible to connect via the username and upload a file successfully to the folder, yet it didn’t appear via the web nor when I connected via the other username. Ah well, so long as it works. I’m sure there’s a sound and logical reason somewhere…


#5

What likely happaned at some time in the past, the “user” for the site was changed. When you complete this function through the dreamhost panel it asks if you want to “move” the files over. It doesn’t “move” then tho, it “copies” them, leaving behind a set of files under an outdated user. The first copy is no longer being used by the web server, but still there. Then you come back “quite awhile” later and notes you have didn’t get updated, they still have that first user name, you log in, upload in image, see others already there but your new one won’t work. Turns out this isn’t the active webspace, it’s an old copy tho which make it look “right” for your attempting.