Ftp'd filenames changed?


#1

when i go to ftp files to my dreamhost space, the now-stored material has randomly changed filenames. how am i causing this error, which appears endemic to dreamhost rather than lying with fetch, which in turn does not change them uploading to anywhere else.


#2

How exactly are they changing? Any pattern?


#3

What are you using to ftp the files?

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#4

fetch assaidbefore


#5

no. here’s the list. it has stripped out the trailing .jpg in each case and substituted a fixed number of random characters for my different-length, but all english, filenames.

ftp://loginname:@tak.dreamhost.com/Pictures/ftptDOhbp
ftp://loginname:@tak.dreamhost.com/Pictures/ftpCda2PR
ftp://loginname:@tak.dreamhost.com/Pictures/ftpfVRgP8
ftp://loginname:@tak.dreamhost.com/Pictures/ftpXUYMKn
ftp://loginname:@tak.dreamhost.com/Pictures/ftpVXTqsG
ftp://loginname:@tak.dreamhost.com/Pictures/ftp2Lpf1w
ftp://loginname:@tak.dreamhost.com/Pictures/ftp6mJGom
ftp://loginname:@tak.dreamhost.com/Pictures/ftpOf2YE4
ftp://loginname:@tak.dreamhost.com/Pictures/ftpMeInOj
ftp://loginname:@tak.dreamhost.com/Pictures/ftpBS0brd
ftp://loginname:@tak.dreamhost.com/Pictures/ftpg60s0J
ftp://loginname:@tak.dreamhost.com/Pictures/ftp8I89p2
ftp://loginname:@tak.dreamhost.com/Pictures/ftph6guUc
ftp://loginname:@tak.dreamhost.com/Pictures/ftp1USoqB
ftp://loginname:@tak.dreamhost.com/Pictures/ftpn0HiMj
ftp://loginname:@tak.dreamhost.com/Pictures/ftpat8cZg
ftp://loginname:@tak.dreamhost.com/Pictures/ftpvYtp07
ftp://loginname:@tak.dreamhost.com/Pictures/ftplopt8z
ftp://loginname:@tak.dreamhost.com/Pictures/ftpVLQuIN
ftp://loginname:@tak.dreamhost.com/Pictures/ftpdginAx
ftp://loginname:@tak.dreamhost.com/Pictures/ftpJS3wb8
ftp://loginname:@tak.dreamhost.com/Pictures/ftpVB8BpI
ftp://loginname:@tak.dreamhost.com/Pictures/ftpgtE7He
ftp://loginname:@tak.dreamhost.com/Pictures/ftpFFfYsF
ftp://loginname:@tak.dreamhost.com/Pictures/ftpvRmxHg
ftp://loginname:@tak.dreamhost.com/Pictures/ftp2FWTf6
ftp://loginname:@tak.dreamhost.com/Pictures/ftpjJapne
ftp://loginname:@tak.dreamhost.com/Pictures/ftpWNxuLQ
ftp://loginname:@tak.dreamhost.com/Pictures/ftpffrm1I
ftp://loginname:@tak.dreamhost.com/Pictures/ftpNFEX7n
ftp://loginname:@tak.dreamhost.com/Pictures/ftpr7uwRz
ftp://loginname:@tak.dreamhost.com/Pictures/ftpOgTnl2
ftp://loginname:@tak.dreamhost.com/Pictures/ftpIKTi8B
ftp://loginname:@tak.dreamhost.com/Pictures/ftpH8HtB8
ftp://loginname:@tak.dreamhost.com/Pictures/ftpW0ZnfL
ftp://loginname:@tak.dreamhost.com/Pictures/ftpG1ufDg
ftp://loginname:@tak.dreamhost.com/Pictures/ftpaCzp1C
ftp://loginname:@tak.dreamhost.com/Pictures/ftpZXrqTL
ftp://loginname:@tak.dreamhost.com/Pictures/ftpxuPgy7
ftp://loginname:@tak.dreamhost.com/Pictures/ftp4jj0Pf
ftp://loginname:@tak.dreamhost.com/Pictures/ftpuzUtoh


#6

I’ve never used fetch, but I’ve never seen that kind of naming before. I’d suspect that you might be seeing the temporary file name that it would rename after upload. Are you logging in as the user that owns the Pictures directory?

Wholly - Use promo code WhollyMindless for full 97$ credit. Let me know if you want something else!


#7

yep, i set up the pictures directory.


#8

Can you try a different FTP program to see if where the problem is?

If nothing else try the webftp system provided by DH and see if that works. - if there’s a problem there too then you know it’s an issue with the server and you should contact support.

–Matttail
art.googlies.net - personal website


#9

It’s a problem with the setting of the “If a file already exists” menu in the Put dialog in Fetch. Here’s a link to the FAQ entry:

http://www.fetchsoftworks.com/FetchWebHelp/Contents/FAQ/TroubleshootingFAQ.html#StrangeNamesAfterPut

And here’s the text:

  1. After I upload my files, they do not have their correct names, instead the names are either gibberish (such as “ftpBYTlvT”) or have “.1” after them.

When you use the Put command, do not set the “If a file already exists:” menu to Pick a different name in the Put dialog. Instead, set it to Replace existing file.

When this menu is set to Pick a different name, Fetch asks the server to pick a new name for your files if ones with the same name already exist, so that your existing files are not replaced. Unfortunately, some servers pick names that have little relation to the file’s original name.

Thanks,

Jim Matthews
Fetch Softworks


#10

Nice! Thanks for taking the time to login and post that. :slight_smile:

–rlparker