FTP using own client


#1

My client wants to use an FTP program I have written, but this isn’t able to connect to the FTP server. I have several other users of this program and they don’t have this problem. I’m running on Windows 7 and using the Microsoft routines InternetOpen and InternetConnect but the latter returns error code 12029 which suggests the password is wrong. And yet if I go into Internet Explorer I can connect to the FTP address and list the files on the server, though if from there I go to “Open FTP Site in File Explorer” I am prompted for the FTP details and it also fails.

Can someone tell me what is different about FTP on DreamHost so that I can modify my FTP program. Thanks.


#2

Go to the “manage users” page in the dreamhost panel. “Edit” the user you are attempting to log in with and make sure the checkbox next to “Disallow FTP?” is not checked.


#3

The box is not checked. I also tried unchecking “Enhanced security?” but this had no effect.


#4

Problem solved - the password had a missing A circumflex! I don’t know how Internet Explorer managed to list the files, but it did.


#5

Does Internet Explorer remember passwords (I know Firefox does if you tell it to)?

If it does, you must have entered the password correctly at some point in the past and IE now uses it from memory.


Mamerto


#6

to test it clear your password history for your ftp sit win IE and see if it misses the symbol I can’t type here. lol! Glad your problem was solved successfully.


#7

No, I’d never entered the correct password until my client wrote to DreamHost and they gave him the correct password. It seems very odd to me that they would use a password containing a character which isn’t on the keyboard. And the fact that A circumflex is actually a non-breaking space in HTML makes me suspect that something is wrong! Anyway, it’s working now. Thanks to all for your suggestions.


#8

Great!

As the old saying goes “if it ain’t (no longer) broke, don’t fix it.” :slight_smile:


Mamerto