FTP Troubles


#1

I have recently noticed a very strange problem regarding uploading/updating of my site.

we host multiple domains on our hosting plan. one of the subdomains appears to not update immediately when doing so via filezilla (ftp).

In particular, the whole site - which is a flash .swf file. I uploaded a new version of the site last night and as of yet the site hasn’t changed.

before you ask…

  • I’ve cleared my cache (i’m using firefox and its set to clear everything on exit)
    -I’ve emptied all cache data from the firewall too including the explorer cache and so on, not that it should matter.

I left it overnight and still no change… very annoying!

I then decided to remove the swf altogether, checked again online and it still showed the old swf version that has been offline for over 24 hours now.

please could someone shed some light on why this is a problem? indeed it is pretty shocking when deadline’s have to be met.


#2

Are the files physically uploaded to the server? Can they be viewed via the browser?
Although you did not mention it, although you probably did do, but when you use Filezilla you sometimes have to use the refesh button to see changes.

That said, a couple of users here have reported problems with file uploads ending up as 0 byte transfers. So you may want to contact support about this problem. It may be linked with the NFS problems I suppose.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!


#3

Managed to answer my own question, though I’m mildly worried as to future updates and such.

I managed to get the site to upload correctly by uploading a .swf with a completely different filename.

previously I had been uploading wractive5.swf to the server.

then renaming the already hosted wractive.swf to wractiveBackup.swf.

then renaming to wractive5.swf to wractive.swf

this should work as I’ve done it before on many servers!

however I uploaded a siteVersion59.swf then renamed to wractive.swf and it worked.

after that I retried wractive5.swf and that worked too.

strange but true. I’d ask the support team to look into this as it is not ideal and there appears to be serious issues regarding your ftp. I’ve never been disconnected so many times either in one session.

regards
keito


#4

Have you disabled browser caching during your testing?