FTP + Transmit + large files = disconnection


#1

I’m using OS X 10.4.2 with Transmit 3.2.1. Basically any time I try to download a large file (50MB+) I get disconnected part way through. I’ve tried it numerous times, and it keeps happening. I’ve tried downloading the same files via command line, and it works perfectly the first try. As far as I can recall I have not been able to download ANY large files with Transmit since I moved to DreamHost. At my old host, it worked perfectly every time (with the exact same software).

Any idea what’s going on here? The knowledge base has Transmit instructions, so clearly there’s no serious incompatibility. It certainly seems to be something about the combination of the two though.

The worst part is that whenever it disconnects, Transmit deletes everything it’s downloaded so far. So I can’t just resume it, I have to start all over :frowning:


#2

Alright… Maybe it isn’t specific to Transmit. I seem to have better luck via command line, but I just ran into the same issue there. Perhaps its time for a support ticket…


#3

I’m another Mac OS 10.4.2 user who uses Transmit and am having similar ftp problems. I’ve also tried Interarchy and Dreamweaver and both have the same problems – constantly dropped connections. I don’t think this is a Transmit issue – FTP seems to be having real problems.


#4

Okay! This should be all fixed!

Here’s what was happening… for some reason (this is still not determined) our system has been reconfiguring our ftp server configuration file a LOT on most servers… like every few minutes. It SHOULD only be doing this when somebody messes with anonymous ftp settings (which is pretty infrequently) but something unrelated seems to be scheduling it.

Anyway, these changes would then schedule an ftp restart on the server, which would drop all current connections! And since this was happening every few minutes, big file uploads couldn’t finish.

For now we’ve fixed it by changing those restarts to just reloads, which re-read the configuration file but don’t drop any ftp connections. In woody (the older version of debian) apparently a restart wouldn’t drop connections… but on machines upgraded to sarge it now does.

Now we’re going to try and figure out why it’s reloading so much when it really shouldn’t need to in the first place!

But nonetheless, changing the restarts to reloads should have fixed the problem for good!

josh!