FTP to server lag?


Hi, sorry I’m a complete newbie to website development.

I use cyberduck FTP program to upload my files to the dreamhost (server?)

I uploaded my whole website, but when I view it on my browser nothing happens, I’ve reloaded my cache but still nothing.

I’ve confirmed on my ftp app and it’s there. I try to access the particular file on the website but it’s not there. Triple checked spelling and captions so i’m sure i didn’t make a mistake. Can anyone help?

could this be just some server lag, and will take a few hours to upload properly or something? Any help would be much appreciated!

Thanks in advance



There’s no lag. Your files belong in the “example.com” directory. If one is not there, it’s because of one of two things:

  1. You haven’t set up your Fully Hosted domain
  2. You logged in as the wrong FTP user (as assigned for the Fully Hosted Domain)




Thanks for the reply Scott!

I’ve had my website up for over a year now and never had this problem before. I don’t think any of the mentioned solutions work.

I’ve tried deleting a file in the ftp program, then I access it through my browser, and it’s still there, even after emptying my cache?


Sometimes an ISP has a cache of the page, which is difficult to get around. What’s the URL, and what’s something I can look for to tell if it’s been updated?



it’s http://www.lazarophotography.com

that’s just odd since i’ve never had this problem before. It’s been a day already and it hasn’t updated.


You probably already have, but double-check that your ftp program is landing you at the root (HOME) folder of the correct user and that you can view and traverse the lazarophotography.com folder.

Next thing to think about would be if you’ve played about with any folder redirection settings in Panel so that the website is actually taking data from another user location on your server.

As Scott has suggested, it could be that your ISP has implemented a transparent proxy or caching system without letting you know (not uncommon) but the first thing to be sure about is that the data is actually being uploaded via the correct user credentials to the correct folder.

If you’re sure you’ve covered all bases and are present at the board right now you could create a quick test.html page, upload it to your site using the ftp credentials you’re having problems with and drop the link here (eg. lazarophotography.com/test.html). That would enable someone here to see if the files you’re manipulating via ftp are indeed in the location that is accessible via your domain url.

Maximum Cash Discount on any plan with MAXCASH


just uploaded it, http://www.lazarophotography.com/test.html

I actually can’t sleep. I’ve been pouring over websites to figure this out, and the support system of my ISP isn’t the best, they promised to call me ASAP. RIGHT!

So far this has been the most helpful place of all. Thanks guys.


[quote]Not Found

The requested URL /test.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.[/quote]
I tried both with the www. prefix and without.

Seems the user/location you’re uploading to needs to be rechecked :wink:

Maximum Cash Discount on any plan with MAXCASH


Your right!

It seems the ftp “server” was transfered from minutemaid to mcgurn. I’m not sure about the technicalities, but why would this happen without prior notice?

Thanks to the both of you for the help. Now I can sleep!



Ahh that explains it. I usually use the website address as the server address in my SFTP client. This method assures that you’re connecting to the same IP as is visible via public browsers.

I really like your landing page at lazarophotography btw, it’s very clean and professional.

Maximum Cash Discount on any plan with MAXCASH