FTP problems


#1

Yesterday I started expiriencing a problem with my FTP. Nothing uploads as the rate is very SLOW (.02KB/S). I’m using WS_FTP and I usually get 50-60 KB/S. It has gotten so bad that I can’t even upload 90KB files. This happened once before, but the problem just kind of went away by itself. My server is stlhood.com if that matters.


#2

How are the download speeds? If they’re not bad, you may consider looking at firewall settings or something of that nature. Are you getting better upload speeds to other locations, or have you tried that yet?


#3

Download speed is excellent. Let me go try another computer for uploads.


#4

Uploads from another computer work fine. Whats wrong with this one?


#5

edited because you’ve already posted back…

Are you running a software firewall on the machine with problems? What OS?


#6

Running Windows XP SP2 on both computers with ZoneAlarm. The computer with the problems receives security updates religiously.


#7

It sounds like that computer has been “Micros*fted” :wink: . I think it likely one of those “updates” changed a firewall setting or did something else that is interfering with your ftp.

Comparing the update history between the two computers might give a clue to an “update” that made the change - then a trip to the Micros*ft KB to see what the ramifications are, and a possible workaround/fix is the approach I think I would take.

Also, with the XP machine that is giving you trouble, have you tried a complete re-boot?

–rlparker


#8

no luck. what sucks is that I had this problem before but I dont remember how I fixed it…

EDIT: Maybe it would help if I described the exact nature of the problem. If I upload a picture say 50kb in size, the transfer will start at 60KB/S then gradually it will drop to 5 KB/S and the transfer will stop at 4 or 5%. The rate will then drop to .052 KB/S and the percentage never changes after that. WS_FTP then usually crashes when I try to stop it.


#9

The only other things that come to mind immediately to check are pretty obvious (forgive me for pointing them out; I understand you have probably tried this stuff):

  1. under the Advanced tab of WS-Ftp, make sure you have Passive Mode checked - that is the default setting. That may be your problem - maybe it somehow got unchecked.

  2. If one machine is fine, and the other is flaky, don’t forget line condition can cause trouble - double check all connections, cables, etc.

Sorry it’s not much, but I did want to make sure you checked both of those items.

–rlparker


#10

wow, it works now but I didn’t do anything. computers are mysterious…

one a side note, we did have a power outage (black out), but I dont know why that would do anything…