FTP problems


OK guys, I’m going crazy here with this problem.

I have Transmit, a FTP program on OS X Tiger for Mac.

I’ve tried logging in using my domain name (technoisworsethanwar.com) and the host name (runts.dreamhost.com). Then I use my user name and password, as outlined to me in the FTP email that Dreamhost sent me.

I’ve tried connecting via FTP, SFTP, FTP with implicit SSL, FTP with SSL/ TLS, WebDAV, and WebDAV HTTPS. Nothing works. Everytime I try to connect, it says “Connection timed out or server hung up.” This literally happens the instant I press connect. There isn’t even really a connect attempt - so I’m assuming the server hung up.

What gives?

I really, really, really don’t want to use the web FTP option

Thank in advance for the help. I’ve looked everywhere for info and can’t find a solution.



Edited: I’m sorry, I originally mis-read your post, and my initial answer did not apply at all to your situation. Have you sucessfully logged in, either via your domain or your server, with this ftp client in the past?


Actually, after doing a ittle more research, my first thoughts might have been valid.-). Whois shows your domain as having been registered today:

Whois Record for Technoisworsethanwar.com
Page Information
Record Type: Domain Name
Server Data
SSL Cert: No valid SSL on this Host
Website Status: No Website

Registry Data
Created: 26-May-2006
Expires: 26-May-2007
Registrar Status: ACTIVE
Whois Server: whois.dreamhost.com

It looks lilke this might have been a very recent transfer to DH. I can browse the single page currently on the site, but am ondering if it is on an “old” host, DNS changes not having yet propagated. The only thing I don’t understand is why you can’t log-on via runt.dreamhost.com, as that should still work regardless of DNS propagation.

Stevie and Joni coming soon?



I’ve been doing fine with using Transmit. All my accounts have shell access enabled. In Transmit, I use SFTP, though plain FTP works. None of the other protocols work for me, which is fine.

Going to runts.dreamhost.com is acceptable until your own domain name propagates.

Seeing how you’re on a Mac, have you tried plain FTP from Terminal?
‘ftp runts.dreamhost.com’ and try your username and password? At least that way you can get a better view of what’s going on, or just user “View -> Show Transcript” in Transmit.

Can you ‘ssh username@runts.dreamhost.com’ from Terminal?



Hey Scott, thanks for the reply.

How do I enable shell access in Transmit? I’m completely ignorant about computers, so if you can put it in idiot terms for me, I’d appreciate it.

I’m also unfamiliar with how to do plain FTP from “Terminal”

At the very least, I’m glad to hear Trasmit works. I bought this program and it works fine for all my other server services. Somehow, Dreamhost is less cooperative.

By the way, I turned on the transcript in Trasmit and it says the host is down. But then I went to Dreamhost to check and it’s not. In fact, the web FTP works fine. But I really don’t want to use the web FTP since I have to upload much larger files than they allow through the web. Thus, I really need to get Transmit to work. Any suggestions you have would be really helpful.



Hey Rlparker,

Thanks for the reply. Yea, I think I’ll leave Stevie and Joni alone for a while. Robbing blind people is probably bad for my karma anyway.

It still doesn’t seem to work. I have no idea what’s going on. I can upload everything fine through the web FTP, but not through my FTP program, Transmit. It doesn’t work either with runts.dreamhost.com or technoisworsethanwar.com. I can’t do what I need to do through the web since I have to upload much larger files than the web interface allows. Any other ideas?

Thanks again


Shell access is granted from the DreamHost Control Panel under Manage Users. That’ll tell you if that account type is Shell or just FTP.

Terminal is in OSX’s Applications->Utilities folder and will bring up a command line where you can manually type in commands such as ‘ftp.’

When did you register or transfer your domain to DreamHost? I’m wondering if DNS hasn’t propagated yet. If your Transcript is showing that the host is down, I’m guessing it’s because the DNS update for your domain hasn’t finished making the rounds yet. Is it working yet? What’s the domain name?