FTP Problem


#1

I am having what I think is a weird problem. I posted a file to FTP via WS_FTP last month for someone else to access and download … I want to delete it now. It’s visible on the web, but when I go into my directory using WS_FTP or Windows XP, the file is NOT there … but it’s there on the web. Can’t delete it there though.

Thoughts? Am I missing something?


#2

Does the file name begin with a period ‘.’ character? If so, then it will be treated as a ‘hidden’ file and may not be visible in your FTP client unless you enable the display of hidden files in your clients options.

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )


#3

No. File name starts with a “t” … I will check hidden files on my client though.


#4

Hmmm… Are you sure the file is where you think it is? It might pay to double check the URL of the file as displayed in your browser.

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )


#5

“Show hidden files” is checked so it’s not that … nice try.

thanks.


#6

Naturally I double/triple checked that. the path is basically: ftp://ftp.mydomain.com/directory/file.zip in the browser … then I go to my domain via WS_FTP or XP, go to that domain folder, go to that folder and NO FILE.

Either it’s WEIRD or I am TOTALLY missing something cause I have poked around EVERYWHERE.

thanks for trying. I may have to actually email Tech Support …


#7

It is definitely a strange problem.

The only other thing that come to mind; Are you logging in with the user that controls that domain? I guess if the domain folder exists, you must be. :slight_smile:

Since you are also using FTP in your browser to access the file, I doubt any .htaccess rewrite rules will be causing confusion, as I believe they only affect HTTP.

That may be the best option. Could you post the cause here when you find out? I am intrigued :slight_smile:

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )


#8

Thought of that too. I logged in as the user I set it up for as well as my user and PWD, which I assume is admin of course.

I will post once I get an answer.

thanks for your thoughts.

jim…


#9

It’s not a mystery … it’s O.E.

I just didn’t have quite the right login and ftp location at the same time. I think I tried every combo but the one I needed. When I logged in with my admin user and pwd I could not see the file … when I logged in via the user and name i set up, I did it via the web and could see the file … when i tried to login via WS_FTP, i used ftp.domainname.com/folder as the domain location and got an error … not thinking, I should have just logged in with the set up user name and pwd to just ftp.domainname.com … the rest would take care of itself … i.e. correct folder and views.

It struck me as weird that I couldn’t see the file logging in with my admin name and HAD to use the user name I set up AND the main domain WITHOUT the folder i was after.

Urgh. Thanks for your suggestions … basically you were right on one of them … I just didn’t quite hit the right combo of login name and location.

jim…


#10

Cool. Well not cool that it was OE, but cool that you have solved the problem and deleted the offending file. :slight_smile:

That is just a side affect of the way users are handled here at DreamHost. Basically, you do not have root access and there is no ‘admin’ user. Your default (DreamHost created) user and any users you create all have their own home directory. When you log-in via FTP using a particular users credentials you will only see the contents of that users home directory, including the web accessible directories for the domains under their control. You will not see the web accessible directories for domains controlled by other users.

This does make things problematic at times, but its just a side affect of DreamHost allowing us to create ‘real’ *nix users.

Anyway, I am glad to hear the problem is resolved.

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )