FTP problem


#1

Hi

I’m having problems FTPing things. It appears as if I’m connected, but once I type a command (any command… even something like “ls”), I get kicked off the FTP. I get an error message saying:

“Connection refused by remote host.”

I’m not sure what’s wrong? Is it a setting I have wrong? The username and password are the correct ones… I’m able to get shell access with them. Just FTP being weird… =(

Any help greatly appreciated. Thanks!


#2

Make sure you are using passive ftp.

  • Dallas
  • DreamHost Head Honcho/Founder

#3

Hi

I’m not sure what passive FTP is? =[ How do I know what kind of FTP I am using? And if I’m not using passive FTP, how do I get it?

Thanks!


#4

Amen!
Im totaly Lost, Im thinking of transfering from Dream host.
Granted I dont know what Im doing… I hired someone to build my web page & upload it, now I cant afford to pay someone to fix my problems.
Im making a few dollars a month now so I dont want to trash can my site!
any students or ones with spare time that are familiar with dream host care to help ?
email me please.
Loni


#5

FTP has two modes, active and passive. Active FTP involves the server making a connection back to your computer which cannot happen if you are behind a cable/dsl router. With Passive FTP, your computer handles all of the connections so it works ok behind the router.

Generally, the passive/active setting is within the FTP application somewhere. Check the connection settings and look for a checkbox that says ‘passive mode’ or possibly ‘PASV’ or something along those lines. You should check the help files for your particular ftp application for more information.

  • Dallas
  • DreamHost Head Honcho/Founder

#6

Hi

Thanks for your help! That did the trick.


#7

Hi,
I’ve had a lot of trouble ftping today. When I can finally get on it says happy.dreamhost.com at the top of fetch and then in the listing it says logs
maildir

It should have my website. but if i feed in my domain it says there’s no such directory. I have passive selected in the preferences.

Can you please tell me EXACTLY what to feed in for

host
user
password
directory
port

thank you.


#8

G’day, octiocti.
Have you checked out the guide on configuring Fetch in the DreamHost Knowledge Base?
All the best,
marsbar


#9

Hi marsbar,

I’m going to try to do this without whining…

Yes … I’ve tried EVERYTHing. whaaaaaa. I’ve been messing with this for hours, almost all day, trying different users and it still wouldn’t work. just now when I was reading your email I realized in this particular instance the problem is that it was the first domain I’ve put on my other account so it was on another (…).dreamhost.com area than what I was trying to put it on. So I changed that and put the correct host in and feel the problem might be more narrow. now i get a -1 error. I’m gong to try to go find the answer myself, but if you should know it please let me know. I’ve done searches all over the internet as well as in the Knowledge Database.

Thank you so much for writing so quickly! I’m under pressure to do a project for my class tomorrow so I really appreciate that I don’t have to wait five or six hours to find this out.

[quote]Have you checked out the guide on configuring Fetch in the DreamHost >Knowledge Base?
All the best,
marsbar[/quote]


#10

Hi again.

I am not sure what the FTP error -1 means, but try turning on Passive Mode in the FTP client preferences.

The details you need to feed to Fetch:
host - e.g. ftp.example.com
user and password - make sure the user has been granted FTP access to the domain
directory - enter your domain name (e.g. example.com)
port range - use the default for now

All the best,
marsbar


#11

Hi Again,
I had to get some sleep and here’s what I’ve worked out. Just to let you know I did not need to type in ftp. but just the domain name in fetch and it does work. HOWEVER it only works for the main account holder and not the individual users that I want to grant permissions. I have gone into that area and checked the domains that I want that particular user to access. But then when i go to sign in on fetch using exactly the same info that gets the main account holder in, except i enter the users name and password and it gives me this error message: "Server file error: domainname.com/: No such file or directory.

This is exactly the same info that gets me in using the main account holder. Do I have to do anythng but grant the user permission by clicking the box by the domain?

This is a student project and all the people in my group need to get into the same domain but should not have access to all the areas that the main account holder has access to.

thank you so much for your assistance. I’ve had some sleep now and am a bit more coherent.


#12

One domain can only be accessed by one ftp user login at a time. Adding additional users does not do what you want. The privileges system in the web control panel is for web-based access to the account information itself and does not affect access to the web site’s ftp files.

  • Dallas
  • DreamHost Head Honcho/Founder

#13

ohhh. okay this is extremely helpful. I’m sure all the individual users can access the files via ftp, right? They need to be able to upload to their own domains. How do I give them access to upload via ftp? Do I need to set up different account names? if so how would I do that. I don’t think that is what I need to do because we have already given two users access and I know one did not have complete access. They use shell accounts and they are very aware of how to do these sorts of things however so it’s a bit different. I wish I could consult them at this moment and save you the trouble, but not possible.

You say only one ftp user can login in at one time, but that is all I’m trying to log in. I’m testing it to see if it will work correctly because the other students all told me they could not log on via fetch with the info I gave them. Then I checked it and sure enough I couldn’t log in using the information I had sent them, exactly as it says on the fetch info page in the KB area of DH.

Only one person needs to log in to one domain at a time, but each of them have to have access, say on separate days, or when we call them and tell them to upload their additions to one domain.

Thanks for deconstructing this problem for me and I’m sorry I’m not faster at catching on what must be such a basic thing.


#14

Sorry, I wasn’t clear. Only one ftp user total can access one domain. A domain is set up under a user and can only be accessed by that one user. When you upload via FTP you are uploading to a specific place in the filesystem where the domain is set up to be served from. The domain’s files only exists in one place on the filesystem and that place is under one user’s home directory.

You may want to look into the Remap Subdirectory function found here:
https://panel.dreamhost.com/index.cgi?tree=domain.mapsubdir&

That will allow you to remap a sub-section of a domain (for example, http://www.domain.com/user2/) so it will be found under /home/user2 instead of /home/user1.

There is no way in our system for more than one ftp user to access and modify the contents of http://www.domain.com/. If more than one person needs to do it, they should all use the same ftp login.

You may want to use WebDAV if you want more than one person to have access to a specific directory. You can find that here:
https://panel.dreamhost.com/index.cgi?tree=goodies.webdav&

Note that you cannot run any CGI or anything of that nature under a WebDAV directory, but it will work fine for basic html and other files.

  • Dallas
  • DreamHost Head Honcho/Founder

#15

G’day, octiocti.
I am glad to find that an expert has come to your aid while I was sleeping - I shall leave you in Dallas’ expert hands. :slight_smile:
All the best,
marsbar