FTP on Android


#1

I’ve been having a fun holiday moving a small Web site into Joomla - using my Android smart phone. It has gone surprisingly well but for one thing.

I am finding it impossible to FTP files to and from the site. Dreamhost now uses Pydio, which I’ve been unable to make work, and the FTP clients I’ve tried time out.

I suspect that I’m missing something obvious, but the Dreamhost wiki seems to be quite out of date.

If someone could run down the proper settings for FTP I’d be grateful. Or suggestions for reliable Android FTP clients.

Oh, for Filezilla for Android!

Followup:

What I did.

  1. logged in at Dreamhost
  2. Manage domains
  3. for the domain, choose WebFTP
  4. I am now kicked into Pydio, choice of a) have app installed, have the app add this domain b) install app and add this domain c) use the Web version of Pydio
  5. Tried b, then a, wouldn’t connect. Server details were NOT carried over to the app. Tried adding details manually, Pydio tries to log in and stalls with a complaint that "no Ajax Explorer installed on this path.

Barry


#2

Smart phone…FTP clients timing out…

Are you doing this over a 3G or 4G connection? Or over wi-fi?

Which browser are you using on Android?

I have used FTP Express as an ftp client on Android and it’s reliable. But I’ve never tried to upload an entire package with it.

You could always try uploading Joomla via the command line. Instructions are here:

and here:

CLI clients for Android:

ConnectBot: https://play.google.com/store/apps/details?id=org.connectbot
Terminal Emulator: https://play.google.com/store/apps/details?id=jackpal.androidterm&hl=en

Never tried this myself, so YMMV.


#3

Also… try SFTP, it may not timeout under conditions that ftp will.


#4

I’ve been using Firefox, and wifi. I’ll track down FTP Express and give it a try.

Somehow I’ve never done FTP via command line. That may be easier.

B


#5

I can install WordPress in about 30 seconds from the command line. Takes much longer via ftp.


#6

You are not alone. I have had the same frustration trying to use Web FTP from my Android device. One of the options is to use Pydio and have the program automatically fill in the server information. That sounds easy, and great. My expectations were set. I pressed the button. It did not happen. No carry over of server information.

By the way, the version of Pydio that says it is native to this device allows SFTP with an option to use an https server address.

I am using a new smartphone using a 4G connection.


#7

Back home now. It appears that the issue with FTP (or SFTP) was somehow related to the guest WIFI at the place we were visiting. I doubt that I’ll ever know.

I’ve been able to log in both on my Linux box using Filezilla, and on the Android phone, but both ran into one thing that may have been the problem:

Your server’s host key is unknown. You have no guarantee that the server is the computer that you think it is.

That warning did not appear when trying to log in at the other location, so I suspect it was the root of the problem.

If time permits I’ll see if Pydio works from here.


#8

I successfully use AndFTP for ftp purposes and S3Anywhere Pro for accessing DreamObjects. I highly recommend both of them. They are by the same company so the UI is similar.