FTP Not Working?


#1

I seem to be having some trouble using both FTP clients and the provided webFTP in order to upload/delete/edit/rename/etc any files on my web space.

Last night a friend of mine logged in to her own ftp area that I had set up for her, and it all worked perfectly fine, but today she can’t even log in.

I seem to be able to only log in using scalise.dreamhost.com instead of ftp.mydomain.com like I normally could. In fact last night she used ftp.mydomain.com to log in, yet today it’s not working at all for either of us.

When I log in with scalise.dreamhost.com, I can view the files in the editor, but can’t save them, nor can I delete, rename, or do anything else to the files.

So is this something going on with DreamHost specifically? Or something that I’m not doing right.


#2

I use just domain.com as the address (and always SFTP).

When you’re logged in, make sure the files are owned by the correct user. If you’ve been moved across servers sometimes the files are left chowned to user ‘apache’.

Maximum Cash Discount on any plan with MAXCASH


#3

I tried just domain.com but that didn’t work either.

When I logged in using scalise.dreamhost.com as the ftp server it showed all of the files as being owned by the proper users, and to be more specific, the error I get when trying to use ftp.domain.com or just domain.com as the ftp server is…

The error occured in file /usr/local/ndn/web/webftp/includes/filesystem.inc.php on line 56.

  • function ftp_openconnection (/usr/local/ndn/web/webftp/modules/browse/browse.inc.php on line 230)
  • function net2ftp_module_printBody (/usr/local/ndn/web/webftp/main.inc.php on line 321)
  • function net2ftp (/usr/local/ndn/web/webftp/index.php on line 58)
    o argument 0: printBody

#4

It would appear to be a problem with WebFTP (although I just tried it and it worked for me).

Try a real ftp client to connect, and connect using SFTP.

If you’re on Windoze, check out WinSCP (it’s free).

Maximum Cash Discount on any plan with MAXCASH


#5

WinSCP worked perfectly, thanks.

But it seems that the webftp isn’t working on port 21. Nor is WinSCP. I can connect to port 22 with WinSCP, but not through the webftp with port 22(times out) so are there any other ports I should try with webftp to connect? My friend doesn’t know how to use ftp clients very well and is familiar with the way a webftp is set up.

EDIT:

Actually now WinSCP is telling me that the server is unexpectedly closing the network connection.


#6

I’d suggest you send in a ticket to Support to let them know that there is a bit of trouble accessing your server via WebFTP and also let them know that port 21 is failing via standalone ftp client as well.

Maximum Cash Discount on any plan with MAXCASH