FTP keeps timing out


#1

Hi, I’m a new DH user. I’ve been trying to upload a 33 mb file since last night but FTP keeps timing out. I’ve try three different clients and keep running into the same problem.

I had some problems uploading to my previous web host but not to this extent. Any ideas?

I’m on a Mac 10.3.9 and am not much of a techie.


#2

as of sunday, sept 18th 3pm/EST i am not able to log into my FTP, keeps timing out as well! hopefully the problem will be fixed soon?

this is what i get:

Response: 200 PORT command successful.
Command: LIST -a
Response: 150 Opening ASCII mode data connection for file list.
Error: Timeout detected!
Error: Could not retrieve directory listing


#3

You should definatly contact support, so they can try and fix this.

-Matttail


#4

Same problem. Slower response times from FTP (between me sending and something happening). Thought it was my computer until it kept doing it :stuck_out_tongue:


#5

Another new DH user. I’m on Mac 10.4.2 and using both Transmit and Interarchy I’m getting dropped ftp connections constantly. really, really annoying. I’ve tried passive and not, doesn’t seem to matter.


#6

I can upload 50-200mb files, easily, quickly and without a hitch. I am on a mac also, using fetch. maybe it’s your server???


#7

We recently made a configuration change that we think may improve this situation. Let us know if you see any change at all.

  • Dallas
  • DreamHost Head Honcho/Founder

#8

When was this change made? I’ve been having serious issues all day long. I’m on basic-rank.pico.dreamhost.com if it helps any.


#9

The change was made to our configuration templates this morning and has been making its way onto the servers. Pico is definitely updated right now.

  • Dallas
  • DreamHost Head Honcho/Founder

#10

I just tried again, twice… Same issue. I’m not seeing any improvement.


#11

I was having prolems yesterday (Wednesday GMT). Getting kind of annoying when the server disconnects me during transfers =/


#12

Okay! This should be all fixed!

Here’s what was happening… for some reason (this is still not determined) our system has been reconfiguring our ftp server configuration file a LOT on most servers… like every few minutes. It SHOULD only be doing this when somebody messes with anonymous ftp settings (which is pretty infrequently) but something unrelated seems to be scheduling it.

Anyway, these changes would then schedule an ftp restart on the server, which would drop all current connections! And since this was happening every few minutes, big file uploads couldn’t finish.

For now we’ve fixed it by changing those restarts to just reloads, which re-read the configuration file but don’t drop any ftp connections. In woody (the older version of debian) apparently a restart wouldn’t drop connections… but on machines upgraded to sarge it now does.

Now we’re going to try and figure out why it’s reloading so much when it really shouldn’t need to in the first place!

But nonetheless, changing the restarts to reloads should have fixed the problem for good!

josh!


#13

Hmm, I’m experiencing the same problem now. I use many different servers without problems, but the Dreamhost FTP server keeps booting me after a few minutes. Same problem happens with SFTP.

Sam