FTP Freezes


Hello, I’ve got an account at dreamhost, and when I try to connect via FTP, it sees:

[18:19:27] SmartFTP v2.0.995.15
[18:19:27] Resolving host name “xxx.dreamhost.com
[18:19:27] Connecting to 64.111.yy.xx Port: 21
[18:19:28] Connected to xxx.dreamhost.com.
[18:19:28] 220 ProFTPD 1.3.0rc2 Server (DreamHost FTP) [64.111.xx.yy]
[18:19:28] USER myUser
[18:19:29] 331 Password required for myUser.
[18:19:29] PASS (hidden)
[18:19:29] 230 User myUser logged in.
[18:19:29] SYST
[18:19:29] 215 UNIX Type: L8
[18:19:29] FEAT
[18:19:29] 211-Features:
[18:19:29] MDTM
[18:19:30] REST STREAM
[18:19:30] SIZE
[18:19:30] 211 End
[18:19:30] PWD
[18:19:30] 257 “/” is current directory.
[18:19:30] TYPE A
[18:19:30] 200 Type set to A
[18:19:30] PASV
[18:19:30] 227 Entering Passive Mode (64,111,xx,yy,133,254).
[18:19:30] Opening data connection to 64.111.xx.yy Port: 34302
[18:19:30] LIST -aL
[18:19:31] 150 Opening ASCII mode data connection for file list
[18:19:31] 890 bytes transferred. (2,99 KB/s) (290 ms)

but it freezes there, it not continues.

It occurs me with many ftp clients, and, sometimes, it shows my the files, but when I move by directories it freezes again, and conection time-out.

[18:20:11] Timeout (40s).
[18:20:11] Active Help: http://www.smartftp.com/support/kb/index.php/74
[18:20:11] Client closed the connection.

What can I do to upload files?

Thank you.


Are you using a Firewall or anything else that may be blocking traffic?

If so, then try again with the Firewall disabled. If this resolves the problem, then you will need to determine what packets are being blocked and configure your Firewall to allow the traffic.


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for details )


I used to have the same problem… my FTP connections would time out most of the times I tried to get a directory listing. This got fixed when I changed DSL routers… apparently my older router was randomly blocking some of the FTP traffic. Check your firewall and router settings as the poster above me said.

Also as a temporary solution you can use SFTP to transfer your files…

use promo code CHEAPESTHOST when you sign up and get $50 off your yearly plan


Yes, I’ve done some upload with SFTP, but it is slower.

I’ll try to connect to ftp in Linux, to discard any software problem. If it still is there, i’ll try to change router config, but in some ftp’s I have no problem.

There are a couple ftp’s that work fine, but other don’t… Why this different?

If I connect with Passive Mode this should not appear.

Where, I’ll try, and sorry if my English is not good enaught (my native language is not English).