FTP Failure - Can't Upload


#1

I am pulling my hair out!

I can log in to my ftp account and I can see all the files.

As soon as I try to upload a file, I get failures. I am using Filezilla and the reason given is Could not start transfer.

Even when I try to upload through Wordpress, I get the error: Unable to create directory /home/mopprime/famblynews.com/wp-content/uploads/2011/10. Is its parent directory writable by the server?

Chmod is 755

I am sure the answer is simple but I’ve gone through the wiki and prior discussion threads and can’t find the answer.


#2

You’ll probably have to contact Support, but I’d try:
Use SFTP (which is always a good idea anyway).
Use Filezilla to make a directory there, just as a test.
If you’re already using SFTP, there’s a chance you’re logged in as the wrong user

Can you upload to any other directories?
Has it worked before?


#3

I updated the user to SFTP. I created a new directory and was able to upload files to it. I cannot upload into existing WP folders – I am 100% positive I went with the Custom option so I could edit. This is so strange-- I’ve never had an issue like this before… but I will say, I don’t think this has ever worked on this particular account. It was just a few days ago, I registered a new domain, did the one click install of Wordpress and I immediately had this issue.

I have an email into support but it’s been hours and I am itchy to upload a new theme.

AND SCOTT… THANK YOU FOR YOUR HELP SO FAR! I appreciate it so very very very much!!!

–Donna


#4

A very short term possible fix would be to chmod 777 the directory. Naturally, it opens the directory to unwanted intrusion, but you can chmod it, try an upload, then set it back to 755 right away.