FTP error: filetype not allowed


#1

Hello,

today I tried to upload an .exe file and i got error saying that filetype is not allowed. When I zipped the file, I was able to upload it, but only if it was .zip format. .7z or .rar or some other filetypes like .mp3 and .img didn’t upload successfully either.

I’m guessing this is not some kind of a limitation to preserve bandwidth, since I’m able to upload .txt files as big as I want.

Ok, I said to myself, I guess there’s a good reason why .exe is prohibited, but come on, some archives and mp3s too?! I am after all paying for this hosting… If it was a problem of spreading viruses or illegal hosting music, my account could be suspended in a second. So, what’s the deal here?

My website presents local business and among other thins, we are offering computer technical support, so it would be the easiest way to point my clients to my website and tell them to download a file and run it, for example, remote support executable. I’m not willing to make a compromise and first zip the file, while some of my clients may not have neccessary software to extract it.

My question: is there is a way to allow uploading of these restricted filetypes.

Best regards,
Brane


#2

I believe these restrictions are only applied to the WebFTP client. If you use a desktop FTP client (there’s a list at http://wiki.dreamhost.com/FTP#FTP_Client_Software), you’ll be able to do whatever you need.

I’m not sure why these file types are restricted on WebFTP, though. I’ll check into that.


#3

Thank you, problem SOLVED.


#4

Web-FTP also won’t let you do anything with paypal/ebay in the title… so much so if there is a folder in there with paypal in it, and you delete another folder it deletes the paypal one… found out when removing a plug-in that had gone wrong on wordpress,