Ftp directories


#1

I created a new ftp user, and I selected that the home location be:

home/mainusername/directoryname

but for some reason, when I do a test connection with that ftp account, it goes to the main home account. Why doesn’t the user only see the “directoryname” location?


If we can send a man to the moon, why can’t we send them all there?


#2

Does ‘home/mainusername/directoryname’ exist?

If you want to make sure the new ftp user only sees his own files then you’d be better off putting his files into his own userspace, such as:

/home/newftpuser

That way, your user won’t be able to move up from landing in /home/mainusername/directoryname and viewing the files in /home/mainusername.

  • wil

#3

yeah, the directory exists, but are you supposed to create the directory before the user?

how do you create his own userspace, such as /home/ftpuser?
I never saw the option available


If we can send a man to the moon, why can’t we send them all there?


#4

You shouldn’t have to. If the directory doesn’t exist, then the system should create one for you. If it does exist, it will just use that one.

You can choose to have the ftp users’s home in /home/ftpuser under the “Home Dir” option in the add new user menu. If you look at the attached screenshot (PDF) then you’ll see that this is also the default option.

http://clients.fbagroup.co.uk/tmp/ftpuser.pdf

(Sorry about the PDF file format. I took a screenshot using Jaguar’s built in screenshot ‘thingy’.)

  • wil

#5

that’s very strange, because it doesn’t seem to be working for me. Perhaps I’ll try changing it to the way you have suggested. The only problem is, you have to delete and create a new user to do that, and it takes hours to update the changes :frowning:


If we can send a man to the moon, why can’t we send them all there?


#6

I’m just looking for a little more help on this issue. I have got the new user working so that they can only see their directory. I prefer to leave it as home/mainusername/directoryname because then the main user can still access the directory too (if I create a different directory ie. home/username, then main user cannot see it).

But, the problem I have is this. The main user doesn’t have any write privledges to the directory.

I would actually like it the other way around so that the main user can create further subdirectories, but the ordinary user cannot edit what the main user creates.

Does that make sense? Is there any way I can do this?


If we can send a man to the moon, why can’t we send them all there?


#7

Well, if you had left it as /home/username then the main user would still be able to view the directory by moving into /home/username. The two users should be within the same group so they should be able to read each others files. Writing however, is restricted to the owner as you noted. I don’t think there’s anything you can do about this – unless you can change the permissions on that direcctory (chmod)? I’ve never tried this but will try later and see what happens.

  • wil

#8

I can’t seem to change the permissions for some reason…when I try to change the permissions so that “group” has write access, I get an error saying that it doesn’t recognise the command, or something like that?


If we can send a man to the moon, why can’t we send them all there?


#9

What command are you trying?

  • wil

#10

chmod 775 (I think that’s the number?)

I tried to do it through ws_ftp…perhaps I should do it from a shell terminal?


If we can send a man to the moon, why can’t we send them all there?


#11

I think ws_ftp has a GUI tool for setting the permissions… you just need to right click on the file or directory or something like that.

You can do it from the command line too.


#12

I realise that, but I keep getting an error message when I try to change the permissions. This is the error:

500-‘SITE CHMOD 775 /DirectoryName’ not understood.
500 SITE not understood.


If we can send a man to the moon, why can’t we send them all there?


#13

I’m caught in that same loop. I set my ftp directory to be under my main user account tree, one directory below the account root. But the owner of this directory is ftpuser, and write permissions are only on for ftpuser. From telnet, main user is not permitted to chmod the ftpdir. But there is no telnet access for the ftpuser. Windows XP Explorer ftp hookup as ftpuser has a permissions window, but won’t permit the change of ftpdir to g+w. And strangely, the Explorer ftp as ftpuser opens on the main users home, not ftpuser’s home.


#14

Ok. I’m out of that loop. And I figured out that the way Dreamhost configures ftp accounts will be all right, maybe better, than what I was trying to do.

1st I looked again at my new ftp account, ftpuser. Saw that I could allow shell access to ftpuser. Set ftpuser to shell, then telneted in as ftpuser. The telnet dropped me right at the ftpdir I setup to be under the main user’s tree. The request for shell access had added a Mail and a log directory under ftpdir. As ftpuser I chmod g+w . Then I telneted in as my main user, and I was able cp some files to ftpdir.

But I also figured out the DH lets a shell user run ftp. So my need to copy stuff from my main user’s tree to the ftpdir so ftpuser could pick it up becomes superfluous. I can have an ftp user account set up as default with the ftp home directory outside the main user’s tree. Any time I need to move data to the alternate ftp users directory, I can just ftp it from the shell.