Frustrated with Rails@DH

software development

#1

Hi,

while I love using rails, making app work here at DH has been frustrating experience.
I had a lot of problems getting one very simple app to work at DH and since I had one that work, I was always looking and trying to copy from it (fcgi and .htaccess, things like that).

It started working yesterday and I was overjoyed. Tonight it is not working again and for the first time, my old app (actually recipes example) is not working either. Nothing was changed in the meantime.

There is nothing in logs. Just waits forever and dies.

This kills all the fun of rails development.

What are your experiences?

Oh, before you point me to wiki, I was using it all along.

Regards,
Zeljko Dakic


#2

DH installed rails-1.1.0 yesterday, but they forgot to install activerecord-1.14.0. As a results, if you’re using the central rails installation and haven’t done anything special, your rails will probably break.

I have filed a support ticket for this.

There should be a way to fix it by disabling the new rails by setting GEM_SKIP, but I haven’t figured out how yet. :frowning:

Tom


#3

Why didn’t they send out a notice about this? I just setup two sites yesterday and now they’re down.

What’s more frustrating is that none of the ways of going back to 1.0 work. i.e. copying rails to vendor or following the instructions here:

Have they got back to you on how long it’s going to take to resolve?

Miles


#4

I just filed the support ticket, so they didn’t get back yet.

Meanwhile, I was able to solve it for myself, but downloading rails and moving the ./vendor/rails directory in the vender directory of my own project.

As for instructions on how to lock a version: I didn’t try that. I assume you used different numbers than the one on that webpage right?
The numbers you should use are listed in /usr/lib/ruby/gems/1.8/specifications/rails-1.0.0.gemspec.
They are listed at the bottom of the file.

Tom


#5

There’s a version for 1.0 on the same page towards the bottom. It uses the same versions as in /usr/lib/ruby/gems/1.8/specifications/rails-1.0.0.gemspec. But thanks for the heads up.

I’ve got a Typo install working by coping Rails to vendor/rails and fiddling with config/environment.rb. I’m not sure which one did the trick since trying each individually didn’t work. My other Rails site, which is custom, didn’t come back to life.

I hope they sort it out soon. It should be a matter of just installing the gem across their servers. Of course I’m assuming my app with just run fine on Rails 1.1. :wink:

Miles


#6

I didn’t plan on switching to 1.1 just yet, but since I now had to fiddle anyway, I went straight for that one.
Works like a charm! Didn’t have to change a single configuration file. Amazing. :slight_smile:

Tom


#7

They also missed actionpack - it’s still at 1.11.2, should be 1.12.0


#8

I tried doing this - uploaded the vendor/rails directory from a fresh rails 1.1 download to my vendor directory on my DH application. But still doesn’t seem to work.

Trying to load script/console from the command line gives me this error:

./script/…/config/…//vendor/rails/activesupport/lib/active_support/dependencies.rb:112:in `const_missing’:NameError: uninitialized constant LoadingModule

What am I missing here?


#9

This is unbelievable. 10 hours of downtime, with no response from Dreamhost. Time to start shopping for a new web hosting company…

In the meantime, can anyone provide good instructions on resolving this? Do I need to setup a local install of rails 1.0, or just get activerecord 1.14.0? And, how do I do this?

Thanks


#10

I got it to work by downloading Rails 1.0 here:

http://rubyforge.org/frs/download.php/7654/rails-1.0.0.tgz

And then moving the vendor/rails dir in there to my app’s vendor/rails dir.

I think I’ll stick with my own version for now. I don’t like this kind of surprise.


#11

This is getting a little ridiculous. Why has it taken so long to fix this, when is seems the solution is simply to update the required gem across their servers?

Has anyone heard from DH on this?

I just started with DH this month, and this incident is leaving a bad taste in my mouth. I hope its not indicative of how things run here…


#12

Still not working. Thanks for pointing how to get around this problem by downloading rails in vendor dir. I think this is the way to go as if you have app that you want to show to the world, you don’t want this kind of unpleasant surprise.
BTW, correct me if I am wrong, but so far DH was really good to respond to problems, this is really not like them. Maybe we all need to post support tickets.

Anyway, sorry to hear that all of you also have problems.

Regards,
Zeljko Dakic


#13

Thanks smackfu, that works!

Looks like it’s time to start finding another web hosting service though. Apparently service isn’t one of dreamhost’s strong points - but breaking things sure is.


#14

If you continue to host here at DH or move to another, consider using your own rails installed under /vendor in any case. If you’re just toying around with Rails it doesn’t make a big difference, but if you have any sort of requirement for uptime you should be in as much control as possible of your environment.

Here’s a quick fix for a Typo blog that you should also be able to apply to any other app (to use Edge Rails):

http://convergentarts.com/articles/2005/11/30/typo-trunk-on-edge-rails

-Tom

-Tom Wilcoxen
convergent arts


#15

Works… Yeee! (hope it will last)

I think this has tought me to always have vendor/rails dir filled.

Thanks.

Zeljko


#16

I understand your frustration and I was frustrated myself too. But just some points to consider:

  • In general, I find DH very open about problems and about their policies. They’re definitely not perfect, but I prefer this to small print gotcha’s.
  • In my case, I’m still in the development phase of the site. That’s when you can consider using a centrail rails installation. It’s lunacy to do this for a live site, because you want to have a many parameters under control as possible. In a way, I’m happy that DH forced me to do what I had been postponing all along. :slight_smile:
  • Finally, look at it this way: this trouble is the result of DH being too enthousiastic and responsive. Think about it: how many hosting companies upgrade a major framework the day after it is release? They definitely need better quality control though…

Tom


#17

Yes, I understand this. My main frustration is that they jumped the gun on this, halfway did an install, then went home for the night… That coupled with their lackluster support. It’s been 13 hours since I put in a support request, and still haven’t heard back. Is that normal with DH?

It is good to know that I can use my own rails release in the vendors folder. I’ll definitely be doing that from now on :slight_smile: