From domain to hosting - caught in a loop


I’ve recently bought my domain through Dreamhost and am attempting to get it hosted so that I can use WordPress.

I am being billed for the domain and for hosting but for some reason, when I click the WordPress install, it says: “You currently have no active domains with us. You’ll need to add one before installing any software!” So I click on “Add”.

That takes me to “Manage Domains” where the heading “All hosted domains on this account” correctly lists the domain I want hosted.

I then click on “Web Hosting” “Add” (it currently reads “none”). That takes me to “Manage Domains”. The “Fully Hosted” section has the correct domain but then the next box asks for “Users, Files, and Paths - create new user (blank) stockholm”. I have no idea what this is and what it is asking for.

Then web and logs directory looks correct.

“Web Options” again confuses me. Should I be going for the recommended PHP CGI? I chose this in one of my circuits and I don’t know whether that was correct for my WordPress objective.

I ignored Google hosted services as I want WordPress and don’t have or require a GMail account. And I think the rest doesn’t apply to me. Or do I need DNS?

Under Dreamhost “Manage Account” - “Domains Hosted” it gives the name of my domain but under “hosting type”, says “none”. Yet, under Hosting Plan it gives a name I gave it when registering, and the billing amount and dates.

I’ve clearly gone wrong somewhere. Please help.


My eyes started glazing over during the loop.

You need to set up a Fully Hosted Domain using the name of the domain you registered. Web Options are…options – You can leave them as is, but I use Fast CGI and Extra Security. This is all in the Fully Hosted box at the top of the page. Ignore the other types of hosting as you scroll down the page.

You should now have a Fully Hosted Domains listed in Manage Domains with a WebFTP option and its own User.

Now with a Fully Hosted Domain, you can add WordPress as an Advanced One-Click.


Hi sdayman, sorry but I think I’m about to grizzle your veteran some more.

I’m in Manage Domains
Do I have to create a new user/stockholm? It is blank right now.

The domain to host name is correct. I’ve selected Remove www — is this OK?

I’ve chosen FastCGI.

I can’t see anything else to change. But, as I wrote already, I can’t see what button I have to click to apply this. What is my next step? What do I click on to get the WebFTP option?

I just went back to the Manage Account page and it still satys the domain has no “hosting type”. The “Domains Hosted” box reads that the domain I have bought has no Hosting Type — “none”. The hosting plan doesn’t appear to be applied to the domain.


You will have to create a new user for that Fully Hosted Domain. There’s usually a dropdown menu for the User, and one option is Create New User, and then a new field will show up where you type the username.

I use “Remove WWW” for all of my domains, since I feel it’s unnecessary. Everything else looks good. The blue button after the “Google Hosted Services” section in Fully Hosted says “Fully Host This Domain,” so click on that. If you’re missing anything, it’ll let you know.


OK, I clicked the button below the first set of Google icons but above the second (this is quite confusing) but it tells me the username is invalid — possibly because I left the stockholm box blank.

What am I supposed to write in here? An admin name? The domain name?[hr]
Hi sdayman,

I made up something for the user name/stockholm. Is this the webmaster’s identity? I don’t understand the purpose of this stage.

Anyhow, it says I’m successful and it should now be fully hosted. So thank you for that.

As I wish to use our own design for the website, do I have to use instead of Or is it possible to have wordpress do all the complicated stuff which, you will have realised by now, will probably not be brilliant for my blood pressure if I am left to my own devices but still use our own design?

Many thanks.


That user is for FTP, should you wish to access the files in your site.

Next step, go to the panel for One-Click installs: Advanced section. Install WordPress to that domain you just set up. As a note, created the software. hosts it for people who don’t have hosting plans anywhere.

WordPress3 is quite a nice setup. It has its own admin panel where you can update its components with no muss, no fuss. And when you want to add components (themes and plugins), it’ll help you with that, as well. Should you not like one of those components, it’s easy to deactivate and/or remove the component.

So go on ahead, install it and explore. It’s easy enough to delete and start over if you really mess it up your first time out.


Thank you so much for your patience and help. I shall now plunge in with gusto and verve thanks to you.

Best wishes,


Oh dear.

Tried to log in at Manage Domains page clicking on WebFTP using User Name and the password generated but getting this message:
An error has occured
Unable to connect to FTP server on port 21.
Are you sure this is the address of the FTP server? This is often different from that of the HTTP (web) server. Please contact your ISP helpdesk or system administrator for help.
The error occured in file /usr/local/ndn/web/webftp/includes/ on line 56.
function ftp_openconnection (/usr/local/ndn/web/webftp/modules/browse/ on line 234)
function net2ftp_module_printBody (/usr/local/ndn/web/webftp/ on line 313)
function net2ftp (/usr/local/ndn/web/webftp/index.php on line 61)
argument 0: printBody

When I tried clicking on FTP it already had the User name and I tried the password but I got this message:
Connection Failed
There was an error connecting to the server “”. Check the server name or IP address, and then try again.

I’m just totally lost.


Don’t bother with the WebFTP. All you need is this:

Install WordPress by using the One-Click feature.


At MySQL it’s telling me I have the Easy Wordpress. Is this from where I restored the DB in my panic?
“speartooth:stachnik” MySQL Server
charlesshaarmurray_com (268 KB)
"Easy wordpress database"
2010-08-09 03:52:20

Shouldn’t this be Advanced? Should I uninstall and start again?

I’m using Dreamweaver. Is this OK for managing the site?[hr]
I clicked the Advanced WordPress one-click, and placed the unzipped folder in my hard drive.

Do I now use the WP Five minute install? Or has it already been installed? Because I’m going through their instructions here:

WP instructions say I now need this:
Database Name used by WordPress (is this charlesshaarmurray_com as at MySQL?)
Username used to access Database (is this the FTP username?)
Password used by Username to access Database (yes, I think I have this)
The hostname of your Database Server (Is this Dreamhost?)

Is the database at MySQL the Easy Wordpress that I mistakenly clicked on yesterday? It does say “Easy” WP. Do I have to delete the database before I can used Advanced Wordpress?


You can ignore that database.

The Advanced One-Click will install all by itself. You shouldn’t have to do anything with a zipfile. When it’s done, it’ll send you email for how to proceed. You don’t need Dreamweaver to manage this. Those questions that WP is asking are answered in the email that the One Click installer will send you.


Aha! I KNEW one-click had to mean that.

Scott, does it look as if I’ve inadvertently installed the Easy WP? I clicked for the Advanced install and, as I wrote earlier, it took me to the WordPress page where it told me to download the WP file. And then nothing, just the WP folder sitting in my download folder. (I put it in my website folder on the hard drive — was that right?)

I never did get an email since yesterday afternoon (London GMT) but I think I deleted the database for that email because it was for Easy install and now there’s nothing here:

There’s now a holding page here but it’s Dreamhost, not WP:

How do I start again?


The Advanced WordPress install is a form you need to fill out. It sounds like you clicked on the WordPress link itself. You need to scroll down and finish filling out the information so it can install it to your domain.


OK. I’m going to tell you what I did wrong.



I failed to scroll all the way down the one-click page. That was a day and a half ago. There, I confessed. The WP button is at the top and I’d been clicking on the link which was taking me to WP where they were telling me to jump through all the hoops. For nearly two days.

Just in case you get someone else with the same problem, do make sure they clicked the correct button. At the bottom of the page. I never got there until just a few minutes ago.

Right. I’m now going to run away and hide.


Hey! Your site is up! Congrats. Have fun experimenting with it.