Friendly urls enabled in Joomla

apps

#1

Could someone tell me why the header pic on some of these pages don’t show? I just enabled friendly urls in the joomla install…after I did the .htaccess rename, as instructed.
http://www.acornmorgans.com/content/category/5/15/29/
yet at the root, there is no problem?
http://www.acornmorgans.com/
Thanks,
Bj.

http://bjdecastro.com


#2

Bj,

The good news is that the header image is showing properly for me. I suspect you are looking at both pages with the same browser you used to view them before the change in .htaccess to provide friendly urls.

You need to clear your cache, and all will be fine! :wink:

–rlparker


#3

Um…I see both the logo (left) and the background horse image (right) on first load. Then…I loose the logo (left side. Letters A M over an acorn) as soon as I move to another page.

I tried your suggestion, but it didn’t work for me. Never seen this before and I can’t find the thorn in my paw, LOL.

Bj.

http://bjdecastro.com


#4

Well, I just clicked every link I could find on your site, and all the images (logo, background horse in header, and embedded images) came out fine.

It’s got to be a cache issue - though sometimes figuring out what is cached where can be frustrating - your ISP could also be caching. Additionally, FireFox doesn’t always completely clear the cache, even when told to do so, and IE has it’s own way of caching certain things.

To be completely sure it isn’t a cache issue, you should clear the cache, and then completely close your browser, then reopen and browse again.

I have not looked at your site in IE - it’s always possible tha IE has mangled your CSS - but that should not apply if it worked before the .htaccess change. Trust me on this, it’s a cache thing.

If all else fails, clear caches, close browsers, disconnect form net…then connect and browse again - I’m betting it will “fix itself” if you do that.

Of course, you could have something very weird happening - write back after you’ve tried those things lwt us know, ok?

–rlparker


#5

Bj,

I just browsed over to your site in IE - and I don’t see your logo at all on any page but the home page (http://www.acornmorgans.com/index.php). Which is what you are reporting. I think your template/css doesn’t like IE. Same result in IE 6 and 7. :open_mouth: .

–rlparker


#6

wow…that is very strange. It didn’t have a problem with that particular file (graphic) before the url programming change. Why is it only that file name?..because I am seeing all other graphics.

I use exptemp configuration module installed in joomla for all the design elements. I don’t have this problem on any other site.

http://bjdecastro.com


#7

It is strange. There are only two thoughts that come to mind, and note that these are only guesses:

1)Have you tried disabling “extra web security” for that domain from the web panel? The mod_security rules that are implemented when you enable “extra web security” are not publicly published (for security reasons) and there have been some reports of certain url combinations getting caught up in one of those rules. It is a simple thing to disable it, try the site, and re-enable it if no improvement.

2)Have you tried setting the path in the background image url to a full url, instead of a relative path… is it possible that the re-write rules that create the “friendly urls” are “borking” the loading of the background image on all but the “home” page because the “path” is no longer valid?

Again, I don’t really know, but I would evaluate both of these approaches to see if either of them work…

Alternately, you might contact the template designer - as this problem doesn’t manifest itself from Firefox, only IE - the designer might have an idea of what’s about.

I also do not know enough about the DX filter used in the template to know if that could be involved - and it might be, given the IE only nature of the “bug”.

I would love to know what you determine the cause to be, when you get to the bottom of it. :wink:

–rlparker


#8

well…after staring at code for days on end, I gave up.
I did get it to do what I wanted by tweaking the style sheet and images.
For anyone else that may have this problem:

  1. I removed the logo from the EXPTemp ‘logo configuration’.
  2. I added the logo with Adobe CS onto the background image.
  3. I renamed the background image, adjusted the margin parameters and used the new image in the EXPTemp ‘background header image configuration’…
    and wha-la…it looks right.

I have tested it on all of my IE machines and it seems to be working fine.
Thanks for all your help RL!

http://bjdecastro.com