Free Image Hosting Script: No Mysql, Very Fast!

software development

#1

Below is a link to a pretty nice script I’ve been trying to get working correctly:
www.image-host-script.com
I can get it to work great, minus the remote URL uploads. If someone can get the remote URL upload to work properly, can you give me a step by step on how? Pleeeeeeease? )

The script is free with a very easy install…check it out. I believe there is a new update coming soon with lots more features, too. I’m almost at the point of giving up on the remote URL uploads though, my knowledge is very limited with this stuff.

Use promo code “THRIFTY50” for $50 OFF
Use promo code “STINGYREFERER” for $1 OFF
http://www.dreamhost.com/hosting.html


#2

crickets sure chirped for this one today lol

Clarification: I am not really promoting this script, it is not mine, I am looking to see if other DH users have the same problems with the URL uploads.

http://forums.digitalpoint.com/showthread.php?p=9259064#post9259064

The domain I am using it on is: www.phreefoto.com

Do I have to start begging someone here to give it a try? Cuz I will. :smiley:

I had one other DH user tell me he had no problems whatseover…which is buggin’ me out.


#3

The “url upload” feature will not work on DreamHost default installations of PHP for precisely the reasons indicated in the the Sitepoint forums thread you linked.

You can’t change this with an .htaccess file alone. No responsible forum contributor to this forum is going to show you how to enable url_fopen here … it is disabled for valid security reasons and if you do not understand why it is disabled, and do not have enough knowledge to re-enable it and mitigate the potential security related implications associated with doing that, then you have no business enabling it … at all. Period.

Use the script, if you want, without that “url upload” feature, or persuade the author to “cURLify” it, or modify the code yourself to use cURL, but do not set allow_url_fopen on in order to work around the problem, as that is simply not a “Good Thing” ™. :wink:

http://wiki.dreamhost.com/Allow_url_fopen

–rlparker
–DreamHost Tech Support


#4

I definitely don’t have the knowledge to re-enable it and mitigate the potential security related implications lol

Thanks for the heads up, I tried uploading the .htaccess file with the code he gave me but it did not work. Looks like the easiest route for a n00b like me is to just try to remove remote url uploads.

Thanks for your reply :slight_smile:

Use promo code “THRIFTY50” for $50 OFF
Use promo code “STINGYREFERER” for $1 OFF
http://www.dreamhost.com/hosting.html


#5

I just had a (very quick) gander at the source and he’s using cURL during the installation process. I see no reason why you couldn’t cajole him into recoding the url upload section to use cURL. He’s obviously comfortable with the command usage and it would definitely be a change “for the better” regarding the final product.

[color=#00CC00]* Doesn’t require fopen[/color] would actually be a nice sales point :wink:

Maximum Cash Discount on any plan with MAXCASH


#6

Well, I am Ali (aka vooler at DP), I am author of the script being discussed.
I just registered to confirm that THERE IS NO CURL BEING USED DURING INSTALLATION.

Besides Idea of using CURL instead of fopen / fsockopen is good, and I will try to add both to let admin select among them and use desired.


#7

My ‘very quick gander’ entailed a search for the term curl in the source and it got hits in install. I looked no further and am at fault for making assumptions in my previous post. I apologise if my implying that you are comfortable with the usage of cURL either upset you or flooded you with requests that you implement it’s use immediately, necessitating a bold all caps response.

Most hosts have cURL compiled these days so you could probably set it up so by default it automatically uses cURL and falls back to fsockopen if cURL is unavailable on the server using some if else in whatever fsockopen procedure you have.

Something like:

[color=#00CC00]if(function_exists(curl_init)) {[/color]

$ch = curl_init();
curl_setopt ($ch, CURLOPT_URL, [color=#0000CC]$_exturl[/color]);
curl_setopt ($ch, CURLOPT_CONNECTTIMEOUT, 30);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
// If binary (could be necessary, depending what you’re doing here)
curl_setopt($ch, CURLOPT_BINARYTRANSFER, 1);
[color=#0000CC]$_gotdata[/color] = curl_exec($ch);
curl_close($ch);

[color=#00CC00]} else {[/color]

[ use fsockopen ]

[color=#00CC00]}[/color]

[ [color=#0000CC]$_gotdata[/color] >> processing >> save local ]

Again, I apologise if my previous assertation caused you any inconvenience.

Maximum Cash Discount on any plan with MAXCASH


#8

That was actually $CURL or $curl that was variable holding current path. Besides it was not agression at all (if it reflected so am sorry for that), used caps were to make headline more readable.

In the DPI 1.1b that we released yesterday night has already been put CURL in. But yet, your example seems more minimal. So better is I first test the example and let it be part of next update.

You might have wrote pseudocode, so I correct it a bit, so that other readers don’t keep asking you same question all the time :slight_smile:

function_exists("function_name_here")