Forward-only email with SMTP


#1

I have the domain mattmccutchen.net hosted at DreamHost. I want email sent to matt@mattmccutchen.net to be forwarded to hashproduct@gmail.com , but I also want the ability to send real email from matt@mattmccutchen.net using the DreamHost SMTP server (as opposed to using a Gmail custom From address, which exposes the underlying account in the Sender header). What is the best way to set this up?

Originally I had matt@mattmccutchen.net set to forward-only, but that didn’t give me access to the SMTP server. I changed the address to “fully hosted” and made it forward to hashproduct@gmail.com , but it also saved the mail in a DreamHost mailbox, which I didn’t need. I attempted to change the address back to forward-only, but the Manage Email panel still shows it as fully hosted but with some information crossed out. Is this the expected behavior? Now it appears that I no longer have the mailbox but still have access to the SMTP server; this is exactly what I need, but I would hate for my setup to depend on a bug in the web panel.


#2

I wouldn’t count on your “new” setup to last forever. I’m guessing that the crossouts were due to the fact that you still had mail on a DreamHost server.

A forward-only mail address doesn’t have a password, so your outbound SMTP access may die someday. I’d recommend you go with Fully Hosted, but set it to limit the Inbox to 10 messages and/or remove messages older than 5 days. And “Even remove unread messages.” Plus, leave the “Save removed messages” option unchecked so they flat out get deleted.

-Scott


#3

[quote]I’m guessing that the crossouts were due to the fact that you still had mail on a DreamHost server.

[/quote]

I don’t think so, because when I first signed up for DreamHost, I converted a fully-hosted address to forward-only before it had a chance to receive any mail and the same thing happened.

[quote]I’d recommend you go with Fully Hosted, but set it to limit the Inbox to 10 messages […]

[/quote]

Thanks for the suggestion. If the SMTP access stops working, I will switch to that setup.


#4

After three years, the “crossed out” address continues to work as desired: forward-only, no mailbox, but SMTP access. I would recommend this solution to anyone with the same needs. Just make a fully hosted address and then change it to forward-only.