Forum on sub-domain can't send SMTP email nor PHP mail!


#1

I have a forum set up on a sub domain (SMF 2.0.7), I then created an email account under the dreamhost panel for the sub domain and the account is working fine under Outlook as example.

The actual forum settings supports PHP Mail (default) and SMTP. Neither option can send out forum related emails. What am I missing here?

SMF error log doesn’t log any errors either. But the email never arrives when you register on the forum or other email based operations. Yet the account works fine under a mail client.

Settings under the forum:
http://i.imgur.com/KhQVy6q.jpg

Pardon my English hope I was able to convey my problem. Please help.


#2

I would recommend not even trying to use DH servers to send mail (this is based on the way things were a few years ago; things may be better now but I wouldn’t count on it)

I have an SMF forum on a subdomain (like you) and it uses a gmail account to send out all its mail, and it has worked fine for several years.

In the SMF administration panel, under “Administration Center » Mail » Settings”, put:

Mail type = SMTP
SMTP server = ssl://smtp.gmail.com
SMTP port = 465
SMTP username = your gmail login
SMTP password = your password

I’m not aware of any problems or difficulties caused by using a different server to send the mail than the one which serves the forum. If anyone knows of any, please say!

P.S. come to think of it, maybe it’s aesthetically important to have the mail sent from the domain name which hosts the forum. You can do that if you have a “google apps” account for the domain. But since google apps is no longer free, there is a serious need for a free or nearly free alternative. This would be a good discussion to have.


#3

Thanks that worked. Pity I can’t use a domain based email to do this. Is this a restriction from Dreamhost?


#4

dreamhost restricts you to sending email thats from yourself. Compare your choices to tomtavoy’s answer. You didn’t have ssl:// in front of mail.yourdomain.com perhaps that’s why. 587 would be my first port choice with dreamhost.