Formmail only sends to one recipient

Recently I have been changing recipients on several formmail forms that have worked fine in the past, sending a form to several recipients.

The required field

results in the email being sent only to the last recipient.

Has DH, changed the $max_recipients variable in formmail to 1?

All suggestions appreciated.

TIA,

Bill

Are both recipients at domains hosted by us?

No.

The first is hosted in the UK and the 2nd is hosted by Dreamhost.

Bill

Our system doesn’t currently allow sending to addresses not hosted with us. This is a really ugly hack to prevent / reduce abuse of the script to spam - because of the nature of our system, even using the nms-cgi script doesn’t protect against some exploits after our modifications. Not the ideal solution…

If you try to send to a single address not hosted with us, you’ll get an error. The easiest way around this would probably be to create a forwarding address at one of your domains, pointing to the outside address.

Hmm. One of the problems we have had with email aliasing, are the spam filters on foreign and esp .edu servers.

I was thinking about using nms-formmail in my own cgi-bin folder.

Will that work?

Thanks for your help,

Bill

Yup. That’ll work. Exploits of form to mail scripts are getting pretty bad, so please use the most restrictive / secure settings you can get to work.