Formmail (NMS) problem - not receiving email


#1

I tested the formmail from http://formmail.dreamhost.com/cgi-bin/formmail.cgi together with my form and it was working and I received the Email after submitting the form.

However I need a custom “Thank you” page for my customers. So I downloaded the formmail script from http://nms-cgi.sourceforge.net

I set it up and it is working with no errors, but I don’t receive the email from it. Why?

Here is the configuration, please help :slight_smile:

[code]
$DEBUGGING = 1;
$emulate_matts_code= 0;
$secure = 1;
$allow_empty_ref = 1;
$max_recipients = 1;
$mailprog = ‘/usr/sbin/sendmail -oi -t’;
$postmaster = ‘office@mydomain.at’;
@referers = qw(mydomain.at);
@allow_mail_to = qw(office@mydomain.at);
@recipients = ();
%recipient_alias = ();
@valid_ENV = qw(REMOTE_HOST REMOTE_ADDR REMOTE_USER HTTP_USER_AGENT);
$locale = ‘’;
$charset = ‘iso-8859-1’;
$date_fmt = ‘%A, %B %d, %Y at %H:%M:%S’;
$style = ‘/css/nms.css’;
$no_content = 0;
$double_spacing = 1;
$wrap_text = 0;
$wrap_style = 1;
$address_style = 0;
$send_confirmation_mail = 0;
$confirmation_text = <<‘END_OF_CONFIRMATION’;
From: office@mydomain.at
Subject: form submission

Thank you for your form submission.

END_OF_CONFIRMATION[/code]

Please help me what is missing or wrong in my configuration? And can’t you show the http://formmail.dreamhost.com/cgi-bin/formmail.cgi script, how it is written, so that I can see what I have to adjust in my own formmail script to make it work? I mean the settings to make it send the email.
[hr]
YIPPIIIIIEEE I HAVE IT :slight_smile:

The problem was this line:

@referers = qw(mydomain.at);

I replaced it with following and it’s working now :slight_smile: :slight_smile: :slight_smile: :wink: :wink: :smiley: :smiley:
@referers = ();