Fork CMS upgrade issues


#1

Hello,

I’m running fork cms on my website and they had a major upgrade that I would want to perform. But I run into some difficulties.

The easy way for it to be upgraded is for it to be a full git clone. Is that possible here?

Secondly, I needed to install “composer” by the following line:

[barker]$ curl -sS https://getcomposer.org/installer | php

But I’m getting the following eror:

Warning: Unexpected character in input:  '\' (ASCII=92) state=1 in - on line 386
#!/usr/bin/env php
Some settings on your machine make Composer unable to work properly.
Make sure that you fix the issues listed below and run this script again:

The phar extension is missing.
Install it or recompile php without --disable-phar

Your PHP (5.2.17) is too old, you must upgrade to PHP 5.3.2 or higher.

I already configured my domain in the web panel to be php 5.4 , is it possible that this is taking more than 30 minutes ? And if that would work how do I make this “phar” thing work ?

thx


#2

Note: The following guesswork is untested.

$ curl -sS https://getcomposer.org/installer | php-5.4 -d 'extension=phar.so --install-dir=[target_directory]'

#3

It actually worked with the following:

curl -sS https://getcomposer.org/installer | php-5.4 -d 'extension=phar.so'

I got:

Downloading...

Composer successfully installed to: /home/cosmicd/composer.phar

Because I had no way to really know where my site’s directory is, it seemed to be installed in the right user dir at least when I removed the whole installdir bit"

Still some problems: by doing the original line (now I also modify it to use php-5.4 , it still gives the error that phar isn’t installed :frowning:

curl -sS https://getcomposer.org/installer | php-5.4

Also, still, according to fork’s guide, I need to be able to use “composer” as a command and that doesn’t work as well.


#4

I typo’d.

The --install-dir should have followed the composer installer instruction before the pipe (it tells composer where to install).


#5

but is that install dire needed ? it seemed to have installed it fine to /home/cosmicd (but not to any domain directory , is that wrong ?


#6

The ForkCMS docs should indicate if it requires composer to be in a particular location.


#7

I guess I’ll have to wait on support before I upgrade to the next version because I can’t risk it. if I use

curl -sS https://getcomposer.org/installer --install-dir=/home/cosmicd/cosmicdreamer.be | php-5.4 -d 'extension=phar.so'

it says --install-dir unknown option.


#8

Okay, I’ve just asked Google and saw this: http://getcomposer.org/doc/00-intro.md#locally so it seems the first way was on the right track. Try ‘quoting’ the extension and then append the extra – dashes before finishing with a path.

A second quick Google for upgrading ForkCMS shows a way to upgrade without all the composer nonsense (it’s all right there in the ForkCMS forum that you’ve already posted in). It appeared to involve uploading the new files and keeping a few folders from the older version.