For PHPiCalendar users

apps

#1

Can you tell me what version of phpICalendar you are using and that is working at DH?

Also can you tell me any specific settings you may have had to set up in config. I have tried setting up both the webdav without php running as cgi; I have tried setting up and running the publish.ical.php with the new 2.0b version. All to no avail.

I keep getting Error: Calendar could not be published. There was an unknown network error (-157).

Would really appreciate if anyone does have it working at DH giving me some particulars.

Thanks much!

deb


#2

Deb,

I am using v2.0, and had some challenges, but they turn out to be no biggie after a few tweaks. First, if you are running webdav, and php as apache, you don’t need the publish script. In that case, you point your client directly at the webdav folder (which client btw?) The reason for this, the webdav folder is owned and writable only by dhapache, which also happens to be who the web server runs as. Nice configuration!!!

I went the second route, so I could have interaction with my non-apache php programs, I just used a non-webdav folder for calendars and pointed to the publish script.

If you want more help, let me know.

hortons at hotmail.com

Shawn


#3

Shawn,
Thanks for letting me know you got things going. I am running the 2.0b version. I am trying to publish with the publish.ical.php script. I don’t have the folder set as webdav, and have turned on php running as cgi.

Trying to use iCal and still get “Calendar could not publish. There was an unknown network error (-157)” The base URL I use in iCal is http://www.domain.com/phpicalendar/calendars/publish.ical.php? Then I use ftp name/password for user/pass.

I have set these things in my config file, which seem to be what needs to be set: *I removed domain and user info. I am also on a dedicated server.

$download_uri = ‘http://www.domain.com/phpicalendar/calendars’;
$default_path = ‘http://www.domain.com/phpicalendar’;
$phpicalendar_publishing = ‘1’;
$ftp_server = ‘server.dreamhost.com’;

$auth_method = ‘ftp’;
$ftp_server = ‘server.dreamhost.com’;
$ftp_calendar_path = ‘/home/user/domain.com/phpicalendar/calendars/’;

Any thoughts as to what I might be missing??

deb


#4

For the ftp publishing to work, PHP must be compiled with ‘–enable-ftp’ which is not the case on the DH hosting accounts.

From what I see, the publish.ical.php script is used to emulate the WebDav publishing, and only seems to work when the authentication mode is “internal”, with a single username/password.

Try changing from ftp to internal authentication and work with the publish script.

I wanted to have more than one user possible, so I the built in authentication in the script and just password protected the directory I wanted to use with htaccess, which is what the script is doing anyway. This allows you to create a multi-user calendar system, htaccess each directory with the correct user credentials. This means the authentication system is set to none.

Shawn


#5

Shawn,

Thanks for the note. I am curious if you are also using iCal?

Didn’t work changing the authentication mode. Umm… Guess I will have to really put my hat on and do some line by line looking.

I am curious about your comment about building in authentication for multiple users and password protecting the directory. I would like to be able to do the same. Essentially what I am trying to do is that my client in Ohio has his appointment calendar which I manage, but I have to do it through Timbuktu. This also means that he can go in and make changes to his calendar and I don’t always know the changes until of course I have scheduled something for him that overlaps an appointment he scheduled.

I was thinking I could use phpicalendar and iCal to manage one calendar on the web with both of us being able to synch/subscribe/update.

Is this what you are doing by making the authentication system none and then using htpasswd/htaccess files to control access? Are you also using the publish.ical.php script then?

I hope I am not being a pain in the you know what. I just have tried several combinations (no webdav, yes webdav, no php as cgi, etc.). I just think it would really resolve the calendar issues with my client and make my life easier if I can get it running :slight_smile:

Thanks in advance for your suggestions,
deb


#6

I am currently only in the experiment stage, but I am using both Mozilla nad Sunbird as clients. I thought I would be happy with the WebDav version, but then there will be no way for any other scripts to interact if I want them to.

I do know that I completely removed the authentication system of the publish.mozilla.php script, password protected the calendars directory, and make sure calendars and the ICS file both have o+w permissions if you are running under apache and you still want access outside of the script.

By using .htaccess I was able to re-enable the authentication, but also allow more than one user to access the file. Neat if you want to keep track of who accesses the calendar.

The publish script ignores the actual authentication scheme and uses a “Built in” htaccess system. The FTP access is ONLY for the admin page.

If you want to e-mail the whole config script I can take a look and compare it to mine, and I will send you my publish script without authentication.

Shawn


#7

Shawn,

Thanks so much for your offer to look at my config script and the further details of your setup. I am one of the starband satellite users that has been affected by the loss satellite, so I am having to resort to dial up at this time (ugh!!!). I will have to get back to this after I have a more consistent access.

I would like though if you could email me directly at dbuxton at infoword.com with your email address and I will send you my config file – only if you really don’t mind taking a look at it.

Thanks again I really appreciate this!
deb


#8

Any luck on this?