Fopen(...) URL file-access is disabled


#1

Hi,

I am setting up my forum after I just moved hosts. I currently use an “RSS Poster” to make threads for new additions to the RSS feeds that I feel suit the forum. Unfortunately, I keep getting these two errors for each feed that’s accessed:

2: fopen(feedlink) [function.fopen]: failed to open stream: no suitable wrapper could be found
File: /Sources/Subs-RSS.php
Line: 314

2: fopen() [function.fopen]: URL file-access is disabled in the server configuration
File: /Sources/Subs-RSS.php
Line: 314

I tried the addon’s “fake cron” mode and Dreamhost’s own cron jobs, but to no avail.

Any suggestions on what I can do?


#2

As URL file-access is disabled, you can’t use that method.

I’ve not got experience of the script you’re running, but does it have any options to use curl instead?

If you do a search on these boards for “url file-access” or “curl” and extend the search history to 1 month, you should find a few threads that might be of use to you.

Cheers,
Karl

web design, development & seo by DigitalVibe


#3

Thanks for the quick reply! I can’t say I know much about PHP, but I’ll see what I can do towards fixing it. Thanks again!

(For the record, I’m using this mod for SMF: http://custom.simplemachines.org/mods/index.php?mod=624 )


#4

Hi Psyche,

I’ve had a quick look on Google, and this post should help you to run the script with curl if URL file-access is disabled.

This actually looks like the same solution I posted to another similar issue with URL file-access, and unfortunately does require some knowledge (or at least confidence) in using php.

Cheers,
Karl

web design, development & seo by DigitalVibe


#5

Upon exploring the Subs-RSS.php file for the script, I did indeed come upon this code. I commented out the fopen and fsock parts, and, with luck, got it working! Thanks very much for your help, I appreciate it. :slight_smile:


#6

Ah brilliant, congrats :slight_smile:

Cheers,
Karl

web design, development & seo by DigitalVibe