Folders on my web are browsible. Any fix?


#1

Hello.
This may be a noobish question but that’s why it’s in this forum :wink: When I access my site, if I hit a folder that doesn’t have a index.html file I get a file browser that shows me all the files in that directory. I’d rather it didn’t do this by default how can I change it to show a error message instead? Thanks very much for any assistance.


#2

Add the line below to your .htaccess file.

Options -indexes

Note: The .htaccess file applies to the directory it is in and all sub-directories, so if you wish to enforce this behavior for the whole domain simply place the .htaccess file in your domains root directory (the directory named the same as your domain).

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )