Flyspray basedir problem



i’m trying to install this flyspray package (note the banner ad for dreamhost on their site) onto a subdomain on my dreamhost account. as per instructions i’ve uploaded an adodb folder, created my database, created my user and set file permissions. everything should be ready to go. however the web-installer for flyspray isnt working and their site suggests that i manually write the config file that makes all the db connections. what’s weird is that even though the web-installer hangs, it still manages to setup the tables on my db.

one of the lines i’m not sure about is the basedir path (Filesystem path to your Flyspray installation). the example config file from the flyspray site has the following:

basedir = “/html/flyspray/”

after poking around these forums i tried using the following:

basedir = “/home/jomni/”

still no luck. can anyone help with the basedir path? or can you see anything in the following that indicates that flyspray will not work with dreamhost? i saw something a couple of days ago that suggesting using .SOMETHING or something like that, but i can’t find it anymore.

basedir = "/home/jomni/"
baseurl = ""
cookiesalt = "6t"
adodbpath = "/home/jomni/"
output_buffering = "on"
passwdcrypt = "md5"
address_rewriting = "0"
reminder_daemon = “0”

dbtype = "mysql"
dbhost = ""
dbname = ""
dbprefix = "projects_"
dbuser = "
dbpass = “*****”[/quote]
any help would be greatly appreciated.


for the base dir try

You might also expirement with taking off the / at the beginning if that doesn’t work.



a phpinfo(); told me that this was my basedir:


i’ve put that in and things are sort of happening now. i can at least see the flyspray pages. however there are major bugs with it at the moment :frowning:


well, somethign else is amis with your setup. In the DH enviroment
is the same as

Which you said you already tried. The .beob refers to the machine you’re on. It’s a reference point phpinfo and other such things pick up that you don’t really want in there. Things will work the same with that part removed, and if you should be moved to an other server at dreamhost leaving it in will break your script.



thanks, i’ve removed .bebo from the config file but it’s still borked.

i’m getting errors like:

[quote]Notice: Undefined variable: COOKIE in /home/.bebo/nastyhob/ on line 8

Notice: Undefined variable: register_text in /home/.bebo/nastyhob/ on line 607

Notice: Undefined index: project_title in /home/.bebo/nastyhob/ on line 607

Notice: Undefined index: flyspray_userid in /home/.bebo/nastyhob/ on line 264[/quote]


Actually, these are notices, rather than errors. Most systems run with notices turned off, but I guess Dreamhost has their PHP set to display notices.

They’re kind of like compiler warnings, in that everybody usually just turns them off and ignores them. Sometimes, they’re important though. For instance, that $COOKIE on scripts/register.php:8 is almost certainly supposed to be $_COOKIE. Apparently there is a $flyspray_prefs array set somewhere, and it’s missing the [‘project_title’] setting.

Most likely what happened with the web setup was that the flyspray.conf.php file was not world writable. From an SSH shell, try clearing it out, running [color=#00CC00]chmod a+w flyspray.conf.php[/color] (in the same directory as the file), then connecting to the web setup script and trying again. Having world writable files can be insecure though, so once the thing is setup, run [color=#00CC00]chmod o-w flyspray.conf.php[/color] to take away world writable permission.